summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Kevin van der Vlist <kevin@kevinvandervlist.nl>2011-06-07 23:13:58 +0200
committerGravatar waker <wakeroid@gmail.com>2011-06-12 13:44:51 +0200
commit1eed84099a8ea6b7bec9167f19d865ab52d6695f (patch)
tree75d4bc6edd4de29bfa2cbe70fa7121527056850e /configure.ac
parentbded25b2bafd98fce08b6cdcd6276b3dcf508cbc (diff)
OpenIndian b148 support (and perhaps other Solaris builds).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2f15a13b..64874ab7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,6 +114,11 @@ fi
dnl check for libdl
AC_CHECK_LIB([dl], [main], [HAVE_DL=yes;DL_LIBS="-ldl";AC_SUBST(DL_LIBS)])
+dnl check libsocket (OpenIndiana)
+AC_CHECK_LIB([socket], [main], [HAVE_SOCKET=yes;DL_LIBS="-lsocket";AC_SUBST(DL_LIBS)])
+dnl check for seperate alloca.h (OpenIndiana)
+AC_CHECK_HEADER([alloca.h],[],[alloca.h not found.])
+
if test "x$enable_portable" != "xno" && test "x$enable_staticlink" != "xno" ; then
AC_DEFINE_UNQUOTED([PORTABLE], [1], [Define if building portable version])
PORTABLE=yes