summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-02-01 20:39:54 +0100
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-02-01 20:39:54 +0100
commit1cc65f741a53ad608a9a150d4076a883002f0738 (patch)
tree7a6c168f2887de0029a498efbd03f7fb4ffe9ff2 /configure.ac
parentfe78eb6e6171c45cd3500bfd8cd35ded4f548c1d (diff)
moved libnotify support into gtkui using --enable-libnotify
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e3d1eafa..8dac0985 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,13 @@ PKG_CHECK_MODULES(DEPS, samplerate)
PKG_CHECK_MODULES(GTKUI_DEPS, gtk+-2.0 >= 2.12 gthread-2.0 glib-2.0, HAVE_GTK=1, NO_GTK=1)
PKG_CHECK_MODULES(ALSA_DEPS, alsa, HAVE_ALSA=1, NO_ALSA=1)
PKG_CHECK_MODULES(FFMPEG_DEPS, libavcodec >= 51.0.0 libavutil libavformat >= 52.0.0, HAVE_FFMPEG=1, NO_FFMPEG=1)
+
+AC_ARG_ENABLE(libnotify, [ --enable-libnotify Enable support for OSD notifications], [libnotify=yes])
+
+if test "x${libnotify}" = "xyes" ; then
+PKG_CHECK_MODULES(NOTIFY_DEPS, libnotify >= 0.4.4, HAVE_NOTIFY=1, NO_NOTIFY=1)
+fi
+
AC_CHECK_LIB([pthread], [main])
AC_CHECK_LIB([dl], [main])
AC_CHECK_LIB([iconv], [main], [have_iconv=yes], [have_iconv=no])
@@ -182,6 +189,15 @@ if test ${HAVE_FFMPEG}; then
AC_SUBST(FFMPEG_DIR)
fi
+AM_CONDITIONAL(HAVE_NOTIFY, test $HAVE_NOTIFY)
+if test ${HAVE_NOTIFY}; then
+ AC_DEFINE(HAVE_NOTIFY,1,[Use libnotify])
+ NOTIFY_DIR="plugins/notification"
+ AC_SUBST(NOTIFY_DEPS_CFLAGS)
+ AC_SUBST(NOTIFY_DEPS_LIBS)
+ AC_SUBST(NOTIFY_DIR)
+fi
+
dnl *** OSS output (partly stolen from audacious)
have_oss=no
@@ -262,8 +278,8 @@ PRINT_PLUGIN_INFO([vfs_curl],[http/ftp streaming support],[test $HAVE_CURL])
dnl PRINT_PLUGIN_INFO([faad2],[aac/mp4 player],[test $HAVE_FAAD && test $HAVE_MP4FF])
PRINT_PLUGIN_INFO([cdda],[cd audio player],[test $HAVE_CDIO && test $HAVE_CDDB])
PRINT_PLUGIN_INFO([gtkui],[GTK user interface],[test $HAVE_GTK])
+PRINT_PLUGIN_INFO([libnotify],[Current track notification],[test $HAVE_NOTIFY])
PRINT_PLUGIN_INFO([ffmpeg],[ffmpeg codecs],[test $HAVE_FFMPEG])
-PRINT_PLUGIN_INFO([notification],[Current track notification],[true])
PRINT_PLUGIN_INFO([oss],[oss output plugin],[test "x$have_oss" = "xyes"])
echo