summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2011-05-04 21:30:07 +0200
committerGravatar waker <wakeroid@gmail.com>2011-05-04 21:30:07 +0200
commit745fa29c0fe4860a67da698c17057d687f1b9bc7 (patch)
treec500e90f45824f411f1b62db4647afb34aac8366 /Makefile.am
parentcb70ca95251e9140aa759d76d18b5fb6e5bfeeaf (diff)
detect the need for linking to libdl.so in configure
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bd39e68d..a8c917c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,7 +42,7 @@ deadbeef_SOURCES =\
sdkdir = $(pkgincludedir)
sdk_HEADERS = deadbeef.h
-deadbeef_LDADD = $(LDADD) $(DEPS_LIBS) $(ICONV_LIB) -lm -ldl -lpthread
+deadbeef_LDADD = $(LDADD) $(DEPS_LIBS) $(ICONV_LIB) $(DL_LIBS) -lm -lpthread
AM_CFLAGS = $(DEPS_CFLAGS) -std=c99
AM_CPPFLAGS = $(DEPS_CFLAGS)