summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-02-04 20:51:32 +0100
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-02-04 20:51:32 +0100
commitf5399c2357d65fab38e42a526f9f49af4d326dea (patch)
treef11a4c0a544cfc20eba182825e972cb807e4ee47
parent1378733bca965af78bda2a55aae1bcf7b0318d26 (diff)
added X11/Xlib check for global hotkeys plugin
-rw-r--r--Makefile.am2
-rw-r--r--README1
-rw-r--r--configure.ac7
3 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 26e75e20..ff3363b0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,11 +4,11 @@ SUBDIRS = gme/Game_Music_Emu-0.5.2\
dumb\
pixmaps\
icons\
- plugins/hotkeys\
plugins/ffap\
plugins/nullout\
plugins/vtx\
plugins/adplug\
+ ${HOTKEYS_DIR}\
${ALSA_DIR}\
${LFM_DIR}\
${MPGMAD_DIR}\
diff --git a/README b/README
index ad212de1..b76dd10d 100644
--- a/README
+++ b/README
@@ -12,6 +12,7 @@ optional/build dependencies
libsndfile: for sndfile plugin
libcdio + libcddb: for cd audio plugin
ffmpeg: for ffmpeg plugin
+ xlib: for global hotkeys
if you want to build from git - install autotools, and run autoreconf
diff --git a/configure.ac b/configure.ac
index 4e2bd679..874fb020 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,6 +196,12 @@ if test ${HAVE_NOTIFY}; then
AC_SUBST(NOTIFY_DEPS_LIBS)
fi
+AC_CHECK_HEADER([X11/Xlib.h], HAVE_XLIB_H=yes)
+if test "x$HAVE_XLIB_H" = "xyes"; then
+ HOTKEYS_DIR="plugins/hotkeys"
+ AC_SUBST(HOTKEYS_DIR)
+fi
+
dnl *** OSS output (partly stolen from audacious)
have_oss=no
@@ -276,6 +282,7 @@ PRINT_PLUGIN_INFO([vfs_curl],[http/ftp streaming support],[test $HAVE_CURL])
dnl PRINT_PLUGIN_INFO([faad2],[aac/mp4 player],[test $HAVE_FAAD && test $HAVE_MP4FF])
PRINT_PLUGIN_INFO([cdda],[cd audio player],[test $HAVE_CDIO && test $HAVE_CDDB])
PRINT_PLUGIN_INFO([gtkui],[GTK user interface],[test $HAVE_GTK])
+PRINT_PLUGIN_INFO([hotkeys],[Global hotkeys support],[test "x$HAVE_XLIB_H" = "xyes"])
PRINT_PLUGIN_INFO([libnotify],[Current track notification],[test $HAVE_NOTIFY])
PRINT_PLUGIN_INFO([ffmpeg],[ffmpeg codecs],[test $HAVE_FFMPEG])
PRINT_PLUGIN_INFO([oss],[oss output plugin],[test "x$have_oss" = "xyes"])