summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2012-10-16 23:20:21 +0200
committerGravatar waker <wakeroid@gmail.com>2012-10-16 23:20:21 +0200
commitf2b4b35cf168081ecc91ab49b61ff978d175f441 (patch)
tree8bbc448ffd362de87a4dc5cfcd89010f1cc6af2c
parent45e1b3ccd5660f65a05fcd9f4b25db092a11228a (diff)
0.5.6-rc2
-rw-r--r--ChangeLog2
-rw-r--r--PORTABLE_VERSION2
-rw-r--r--configure.ac14
3 files changed, 13 insertions, 5 deletions
diff --git a/ChangeLog b/ChangeLog
index b57ae215..5ec3cc09 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -25,7 +25,7 @@ version 0.5.6
converter: fixed handling "/" in filenames; fixed tag-writing to files which have special characters
fixed resuming last session in shuffle albums mode
fixed several libmms freeze/hang/crash bugs
- vorbis: update waveformat dynamically, so now it's possible to listen the radious which switch between mono and stereo dynamically
+ vorbis: update waveformat dynamically, so now it's possible to listen the radios which switch between mono and stereo dynamically
mp3: fixed samplerate shown in the track properties
version 0.5.5
diff --git a/PORTABLE_VERSION b/PORTABLE_VERSION
index 9686a8ef..8b80fc2e 100644
--- a/PORTABLE_VERSION
+++ b/PORTABLE_VERSION
@@ -1 +1 @@
-0.5.6-rc1
+0.5.6-rc2
diff --git a/configure.ac b/configure.ac
index 0a14837b..d0bd12e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([deadbeef], [devel])
+AC_INIT([deadbeef], [0.5.6-rc2])
AC_CONFIG_HEADER(config.h)
@@ -176,7 +176,11 @@ fi
AC_SUBST(ZIP_LIBS)
if test "x$enable_gtk3" == "xyes" ; then
- PKG_CHECK_MODULES(GTK3_DEPS, gtk+-3.0 >= 3.0 gthread-2.0 glib-2.0, HAVE_GTK3=yes, HAVE_GTK3=no)
+ if test "x$enable_staticlink" != "xno" ; then
+ HAVE_GTK3=yes
+ else
+ PKG_CHECK_MODULES(GTK3_DEPS, gtk+-3.0 >= 3.0 gthread-2.0 glib-2.0, HAVE_GTK3=yes, HAVE_GTK3=no)
+ fi
AC_CHECK_LIB([SM], [main], [HAVE_SM=yes;SM_LIBS="-lSM";AC_SUBST(SM_LIBS)])
AC_CHECK_LIB([ICE], [main], [HAVE_ICE=yes;ICE_LIBS="-lICE";AC_SUBST(ICE_LIBS)])
else
@@ -184,7 +188,11 @@ else
fi
if test "x$enable_gtk2" == "xyes" ; then
- PKG_CHECK_MODULES(GTK2_DEPS, gtk+-2.0 >= 2.12 gthread-2.0 glib-2.0, HAVE_GTK2=yes, HAVE_GTK2=no)
+ if test "x$enable_staticlink" != "xno" ; then
+ HAVE_GTK2=yes
+ else
+ PKG_CHECK_MODULES(GTK2_DEPS, gtk+-2.0 >= 2.12 gthread-2.0 glib-2.0, HAVE_GTK2=yes, HAVE_GTK2=no)
+ fi
AC_CHECK_LIB([SM], [main], [HAVE_SM=yes;SM_LIBS="-lSM";AC_SUBST(SM_LIBS)])
AC_CHECK_LIB([ICE], [main], [HAVE_ICE=yes;ICE_LIBS="-lICE";AC_SUBST(ICE_LIBS)])
else