summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2011-04-18 22:10:01 +0200
committerGravatar waker <wakeroid@gmail.com>2011-04-18 22:12:04 +0200
commitd80680ca66409df7bef4ff032e1b6d309f6855b4 (patch)
treea6d85860d5da8750115c9e7518365cb977a7631f
parent37788320ca794744eb0e382b5bd95bf6c4241c9f (diff)
0.5.0-beta1 build
-rw-r--r--configure.ac2
-rwxr-xr-xscripts/portable_package_static.sh53
-rwxr-xr-xscripts/portable_postbuild.sh3
3 files changed, 57 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 09942782..97228d05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([deadbeef], [devel])
+AC_INIT([deadbeef], [0.5.0-beta1])
AC_CONFIG_HEADER(config.h)
diff --git a/scripts/portable_package_static.sh b/scripts/portable_package_static.sh
new file mode 100755
index 00000000..bbe583ca
--- /dev/null
+++ b/scripts/portable_package_static.sh
@@ -0,0 +1,53 @@
+#!/bin/sh
+
+# package for distribution
+VERSION=`cat PORTABLE_VERSION | perl -ne 'chomp and print'`
+BUILD=`cat PORTABLE_BUILD | perl -ne 'chomp and print'`
+
+# main distro
+SRCDIR=deadbeef-$VERSION
+PLUGDIR=$SRCDIR/plugins
+DOCDIR=$SRCDIR/doc
+PIXMAPDIR=$SRCDIR/pixmaps
+
+rm portable_out/build/deadbeef-$VERSION-static.tar.bz2
+
+cd portable
+tar jcvf ../portable_out/build/deadbeef-$VERSION-static.tar.bz2\
+ $SRCDIR/deadbeef\
+ $SRCDIR/deadbeef.png\
+ $DOCDIR\
+ $PLUGDIR/aac.so\
+ $PLUGDIR/adplug.so\
+ $PLUGDIR/alsa.so\
+ $PLUGDIR/artwork.so\
+ $PLUGDIR/cdda.so\
+ $PLUGDIR/dca.so\
+ $PLUGDIR/ddb_gui_GTK2.fallback.so\
+ $PLUGDIR/ddb_gui_GTK2.so\
+ $PLUGDIR/ffap.so\
+ $PLUGDIR/ffmpeg.so\
+ $PLUGDIR/flac.so\
+ $PLUGDIR/gme.so\
+ $PLUGDIR/hotkeys.so\
+ $PLUGDIR/lastfm.so\
+ $PLUGDIR/m3u.so\
+ $PLUGDIR/mms.so\
+ $PLUGDIR/mpgmad.so\
+ $PLUGDIR/musepack.so\
+ $PLUGDIR/notify.so\
+ $PLUGDIR/nullout.so\
+ $PLUGDIR/oss.so\
+ $PLUGDIR/shellexec.so\
+ $PLUGDIR/sid.so\
+ $PLUGDIR/sndfile.so\
+ $PLUGDIR/supereq.so\
+ $PLUGDIR/tta.so\
+ $PLUGDIR/vfs_curl.so\
+ $PLUGDIR/vfs_zip.so\
+ $PLUGDIR/vorbis.so\
+ $PLUGDIR/vtx.so\
+ $PLUGDIR/wavpack.so\
+ $PLUGDIR/wildmidi.so\
+ $PIXMAPDIR
+cd ..
diff --git a/scripts/portable_postbuild.sh b/scripts/portable_postbuild.sh
index 51adbec2..ad2ec8df 100755
--- a/scripts/portable_postbuild.sh
+++ b/scripts/portable_postbuild.sh
@@ -5,6 +5,9 @@ OUTDIR=portable/deadbeef-$VERSION
PLUGDIR=$OUTDIR/plugins
DOCDIR=$OUTDIR/doc
PIXMAPDIR=$OUTDIR/pixmaps
+
+rm -rf $OUTDIR
+
mkdir -p $PLUGDIR
mkdir -p $DOCDIR
mkdir -p $PIXMAPDIR