summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2015-01-31 17:19:22 -0500
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2015-01-31 17:19:22 -0500
commitc2d232405dff3c653d8518d91cb1894bb1c4bcaf (patch)
treed83322095fa43c1d7f47ab6e78f79723622cce4c
parentcfe902d9dee2e85243ce26b8754e4b520c747ab7 (diff)
Use #!/usr/bin/dh-exec in relevant .install files
A number of .install files reference the DEB_HOST_MULTIARCH variable. Make these files scripts run by dh-exec so it’s expanded properly.
-rw-r--r--debian/control1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-aac.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-alac.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-alsa.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-artwork.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-cdda.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-converter-core.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-converter-gtk2.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-converter-gtk3.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-curl.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-flac.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-gui-gtk2.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-gui-gtk3.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-hotkeys.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-lastfm.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-libavcodec.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-m3u.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-mono2stereo.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-mp3.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-notify.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-nullout.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-oss.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-pltbrowser-gtk2.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-pltbrowser-gtk3.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-pulse.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-resampler.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-shellexec-core.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-shellexec-gtk2.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-shellexec-gtk3.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-sndfile.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-supereq.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-tta.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-vorbis.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-vtx.install1
-rwxr-xr-x[-rw-r--r--]debian/deadbeef-plugin-wavpack.install1
35 files changed, 35 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 1ee4b60e..31535ed5 100644
--- a/debian/control
+++ b/debian/control
@@ -5,6 +5,7 @@ Maintainer: Benjamin Barenblat <bbaren@mit.edu>
Build-Depends:
debhelper (>= 9),
dh-autoreconf,
+ dh-exec,
intltool,
libasound2-dev,
libavformat-dev,
diff --git a/debian/deadbeef-plugin-aac.install b/debian/deadbeef-plugin-aac.install
index dcfaaf79..1ac3796f 100644..100755
--- a/debian/deadbeef-plugin-aac.install
+++ b/debian/deadbeef-plugin-aac.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/aac.so
diff --git a/debian/deadbeef-plugin-alac.install b/debian/deadbeef-plugin-alac.install
index 12053b52..6641c220 100644..100755
--- a/debian/deadbeef-plugin-alac.install
+++ b/debian/deadbeef-plugin-alac.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/alac.so
diff --git a/debian/deadbeef-plugin-alsa.install b/debian/deadbeef-plugin-alsa.install
index e88dbca5..61c10779 100644..100755
--- a/debian/deadbeef-plugin-alsa.install
+++ b/debian/deadbeef-plugin-alsa.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/alsa.so
diff --git a/debian/deadbeef-plugin-artwork.install b/debian/deadbeef-plugin-artwork.install
index 86c64052..8e2818c0 100644..100755
--- a/debian/deadbeef-plugin-artwork.install
+++ b/debian/deadbeef-plugin-artwork.install
@@ -1,2 +1,3 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/artwork.so
usr/share/deadbeef/pixmaps/noartwork.png
diff --git a/debian/deadbeef-plugin-cdda.install b/debian/deadbeef-plugin-cdda.install
index 5dcddf65..012d9e46 100644..100755
--- a/debian/deadbeef-plugin-cdda.install
+++ b/debian/deadbeef-plugin-cdda.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/cdda.so
diff --git a/debian/deadbeef-plugin-converter-core.install b/debian/deadbeef-plugin-converter-core.install
index 2fa12874..0dacf6af 100644..100755
--- a/debian/deadbeef-plugin-converter-core.install
+++ b/debian/deadbeef-plugin-converter-core.install
@@ -1,2 +1,3 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/converter.so
usr/share/deadbeef/convpresets
diff --git a/debian/deadbeef-plugin-converter-gtk2.install b/debian/deadbeef-plugin-converter-gtk2.install
index a35fe809..1a78c896 100644..100755
--- a/debian/deadbeef-plugin-converter-gtk2.install
+++ b/debian/deadbeef-plugin-converter-gtk2.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/converter_gtk2.so
diff --git a/debian/deadbeef-plugin-converter-gtk3.install b/debian/deadbeef-plugin-converter-gtk3.install
index 1baccdcc..ae2ece29 100644..100755
--- a/debian/deadbeef-plugin-converter-gtk3.install
+++ b/debian/deadbeef-plugin-converter-gtk3.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/converter_gtk3.so
diff --git a/debian/deadbeef-plugin-curl.install b/debian/deadbeef-plugin-curl.install
index f7413cb4..f4508ab0 100644..100755
--- a/debian/deadbeef-plugin-curl.install
+++ b/debian/deadbeef-plugin-curl.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/vfs_curl.so
diff --git a/debian/deadbeef-plugin-flac.install b/debian/deadbeef-plugin-flac.install
index 1a3e04cc..bd68c82f 100644..100755
--- a/debian/deadbeef-plugin-flac.install
+++ b/debian/deadbeef-plugin-flac.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/flac.so
diff --git a/debian/deadbeef-plugin-gui-gtk2.install b/debian/deadbeef-plugin-gui-gtk2.install
index 17a8ec78..4360c5eb 100644..100755
--- a/debian/deadbeef-plugin-gui-gtk2.install
+++ b/debian/deadbeef-plugin-gui-gtk2.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/ddb_gui_GTK2.so
diff --git a/debian/deadbeef-plugin-gui-gtk3.install b/debian/deadbeef-plugin-gui-gtk3.install
index 01b6237e..56a968a4 100644..100755
--- a/debian/deadbeef-plugin-gui-gtk3.install
+++ b/debian/deadbeef-plugin-gui-gtk3.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/ddb_gui_GTK3.so
diff --git a/debian/deadbeef-plugin-hotkeys.install b/debian/deadbeef-plugin-hotkeys.install
index 04578c6e..d7ff49f0 100644..100755
--- a/debian/deadbeef-plugin-hotkeys.install
+++ b/debian/deadbeef-plugin-hotkeys.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/hotkeys.so
diff --git a/debian/deadbeef-plugin-lastfm.install b/debian/deadbeef-plugin-lastfm.install
index 4b46b109..6d6eba1a 100644..100755
--- a/debian/deadbeef-plugin-lastfm.install
+++ b/debian/deadbeef-plugin-lastfm.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/lastfm.so
diff --git a/debian/deadbeef-plugin-libavcodec.install b/debian/deadbeef-plugin-libavcodec.install
index a3ba2b08..0254e498 100644..100755
--- a/debian/deadbeef-plugin-libavcodec.install
+++ b/debian/deadbeef-plugin-libavcodec.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/ffmpeg.so
diff --git a/debian/deadbeef-plugin-m3u.install b/debian/deadbeef-plugin-m3u.install
index 2cfe5b46..4259009b 100644..100755
--- a/debian/deadbeef-plugin-m3u.install
+++ b/debian/deadbeef-plugin-m3u.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/m3u.so
diff --git a/debian/deadbeef-plugin-mono2stereo.install b/debian/deadbeef-plugin-mono2stereo.install
index 2a0f3ab0..72f73f5c 100644..100755
--- a/debian/deadbeef-plugin-mono2stereo.install
+++ b/debian/deadbeef-plugin-mono2stereo.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/ddb_mono2stereo.so
diff --git a/debian/deadbeef-plugin-mp3.install b/debian/deadbeef-plugin-mp3.install
index e0c2465b..a9830582 100644..100755
--- a/debian/deadbeef-plugin-mp3.install
+++ b/debian/deadbeef-plugin-mp3.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/mpgmad.so
diff --git a/debian/deadbeef-plugin-notify.install b/debian/deadbeef-plugin-notify.install
index 8a41f511..244bfae6 100644..100755
--- a/debian/deadbeef-plugin-notify.install
+++ b/debian/deadbeef-plugin-notify.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/notify.so
diff --git a/debian/deadbeef-plugin-nullout.install b/debian/deadbeef-plugin-nullout.install
index 71e5418b..e7af080a 100644..100755
--- a/debian/deadbeef-plugin-nullout.install
+++ b/debian/deadbeef-plugin-nullout.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/nullout.so
diff --git a/debian/deadbeef-plugin-oss.install b/debian/deadbeef-plugin-oss.install
index 1424b0d4..9a3594a2 100644..100755
--- a/debian/deadbeef-plugin-oss.install
+++ b/debian/deadbeef-plugin-oss.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/oss.so
diff --git a/debian/deadbeef-plugin-pltbrowser-gtk2.install b/debian/deadbeef-plugin-pltbrowser-gtk2.install
index 0087ce54..24d84bb5 100644..100755
--- a/debian/deadbeef-plugin-pltbrowser-gtk2.install
+++ b/debian/deadbeef-plugin-pltbrowser-gtk2.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/pltbrowser_gtk2.so
diff --git a/debian/deadbeef-plugin-pltbrowser-gtk3.install b/debian/deadbeef-plugin-pltbrowser-gtk3.install
index a8021b19..c6214334 100644..100755
--- a/debian/deadbeef-plugin-pltbrowser-gtk3.install
+++ b/debian/deadbeef-plugin-pltbrowser-gtk3.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/pltbrowser_gtk3.so
diff --git a/debian/deadbeef-plugin-pulse.install b/debian/deadbeef-plugin-pulse.install
index 2b02f7bb..d5ff2dc0 100644..100755
--- a/debian/deadbeef-plugin-pulse.install
+++ b/debian/deadbeef-plugin-pulse.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/pulse.so
diff --git a/debian/deadbeef-plugin-resampler.install b/debian/deadbeef-plugin-resampler.install
index b2eef6da..d42f45f9 100644..100755
--- a/debian/deadbeef-plugin-resampler.install
+++ b/debian/deadbeef-plugin-resampler.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/dsp_libsrc.so
diff --git a/debian/deadbeef-plugin-shellexec-core.install b/debian/deadbeef-plugin-shellexec-core.install
index a221a7e3..dcb80ae8 100644..100755
--- a/debian/deadbeef-plugin-shellexec-core.install
+++ b/debian/deadbeef-plugin-shellexec-core.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/shellexec.so
diff --git a/debian/deadbeef-plugin-shellexec-gtk2.install b/debian/deadbeef-plugin-shellexec-gtk2.install
index 169bddba..ca7e163e 100644..100755
--- a/debian/deadbeef-plugin-shellexec-gtk2.install
+++ b/debian/deadbeef-plugin-shellexec-gtk2.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/shellexecui_gtk2.so
diff --git a/debian/deadbeef-plugin-shellexec-gtk3.install b/debian/deadbeef-plugin-shellexec-gtk3.install
index 32aca5f3..270a3dea 100644..100755
--- a/debian/deadbeef-plugin-shellexec-gtk3.install
+++ b/debian/deadbeef-plugin-shellexec-gtk3.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/shellexecui_gtk3.so
diff --git a/debian/deadbeef-plugin-sndfile.install b/debian/deadbeef-plugin-sndfile.install
index 582eb654..2f4040f2 100644..100755
--- a/debian/deadbeef-plugin-sndfile.install
+++ b/debian/deadbeef-plugin-sndfile.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/sndfile.so
diff --git a/debian/deadbeef-plugin-supereq.install b/debian/deadbeef-plugin-supereq.install
index 9847c3dc..9e2099b3 100644..100755
--- a/debian/deadbeef-plugin-supereq.install
+++ b/debian/deadbeef-plugin-supereq.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/supereq.so
diff --git a/debian/deadbeef-plugin-tta.install b/debian/deadbeef-plugin-tta.install
index aefc4776..edae5fb8 100644..100755
--- a/debian/deadbeef-plugin-tta.install
+++ b/debian/deadbeef-plugin-tta.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/tta.so
diff --git a/debian/deadbeef-plugin-vorbis.install b/debian/deadbeef-plugin-vorbis.install
index 1fce5be9..0fbe12b1 100644..100755
--- a/debian/deadbeef-plugin-vorbis.install
+++ b/debian/deadbeef-plugin-vorbis.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/vorbis.so
diff --git a/debian/deadbeef-plugin-vtx.install b/debian/deadbeef-plugin-vtx.install
index d2dbe946..b1176e70 100644..100755
--- a/debian/deadbeef-plugin-vtx.install
+++ b/debian/deadbeef-plugin-vtx.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/vtx.so
diff --git a/debian/deadbeef-plugin-wavpack.install b/debian/deadbeef-plugin-wavpack.install
index 0406b89a..2ffca194 100644..100755
--- a/debian/deadbeef-plugin-wavpack.install
+++ b/debian/deadbeef-plugin-wavpack.install
@@ -1 +1,2 @@
+#!/usr/bin/dh-exec
usr/lib/${DEB_HOST_MULTIARCH}/deadbeef/wavpack.so