summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-03-28 09:57:49 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-03-28 09:57:49 +0200
commit9c806f8aade3e95ce2a8d334be8a4123363116ac (patch)
tree8d7d803cdbd2fef299c50ca53b522d82dd53abf5
parent8a105a63ee117ade3e9e29c0f3e9e577a6882c18 (diff)
deleted taglib plugin prototype
-rw-r--r--plugins/taglib/Makefile.am8
-rw-r--r--plugins/taglib/taglib.c53
-rw-r--r--plugins/taglib/taglib.h59
3 files changed, 0 insertions, 120 deletions
diff --git a/plugins/taglib/Makefile.am b/plugins/taglib/Makefile.am
deleted file mode 100644
index 76485739..00000000
--- a/plugins/taglib/Makefile.am
+++ /dev/null
@@ -1,8 +0,0 @@
-taglibdir = $(libdir)/$(PACKAGE)
-pkglib_LTLIBRARIES = taglib.la
-taglib_la_SOURCES = taglib.c
-
-taglib_la_LDFLAGS = -module
-
-taglib_la_LIBADD = $(LDADD) $(TAGLIB_DEPS_LIBS)
-AM_CFLAGS = -std=c99 $(TAGLIB_DEPS_CFLAGS)
diff --git a/plugins/taglib/taglib.c b/plugins/taglib/taglib.c
deleted file mode 100644
index b260ad2d..00000000
--- a/plugins/taglib/taglib.c
+++ /dev/null
@@ -1,53 +0,0 @@
-/*
- DeaDBeeF - ultimate music player for GNU/Linux systems with X11
- Copyright (C) 2009-2010 Alexey Yakovenko <waker@users.sourceforge.net>
-
- This program is free software; you can redistribute it and/or
- modify it under the terms of the GNU General Public License
- as published by the Free Software Foundation; either version 2
- of the License, or (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-*/
-#include <tag_c.h>
-#include "../../deadbeef.h"
-#include "taglib.h"
-
-DB_functions_t *deadbeef;
-
-int
-taglib_plugin_start (void) {
- return 0;
-}
-
-int
-taglib_plugin_stop (void) {
- return 0;
-}
-
-static DB_taglib_t plugin = {
- .misc.plugin.api_vmajor = DB_API_VERSION_MAJOR,
- .misc.plugin.api_vminor = DB_API_VERSION_MINOR,
- .misc.plugin.type = DB_PLUGIN_MISC,
- .misc.plugin.id = "taglib",
- .misc.plugin.name = "Taglib tag writer",
- .misc.plugin.descr = "Tag writing plugin based on Taglib",
- .misc.plugin.author = "Alexey Yakovenko",
- .misc.plugin.email = "waker@users.sourceforge.net",
- .misc.plugin.website = "http://deadbeef.sf.net",
- .misc.plugin.start = taglib_plugin_start,
- .misc.plugin.stop = taglib_plugin_stop,
-};
-
-DB_plugin_t *
-taglib_load (DB_functions_t *api) {
- deadbeef = api;
- return DB_PLUGIN (&plugin);
-}
diff --git a/plugins/taglib/taglib.h b/plugins/taglib/taglib.h
deleted file mode 100644
index c340ef10..00000000
--- a/plugins/taglib/taglib.h
+++ /dev/null
@@ -1,59 +0,0 @@
-/*
- DeaDBeeF - ultimate music player for GNU/Linux systems with X11
- Copyright (C) 2009-2010 Alexey Yakovenko <waker@users.sourceforge.net>
-
- This program is free software; you can redistribute it and/or
- modify it under the terms of the GNU General Public License
- as published by the Free Software Foundation; either version 2
- of the License, or (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-*/
-#ifndef __TAGLIB_H
-#define __TAGLIB_H
-
-typedef void * DB_taglib_file_t;
-
-enum {
- DB_TAG_ID3V1,
- DB_TAG_ID3V2,
- DB_TAG_APEV2,
-} DB_tag_type_t;
-
-typedef struct DB_taglib_s {
- DB_misc_t misc;
-
- DB_taglib_file_t (*open) (const char *fname);
-
- void (*set_mp3_tag_types) (DB_taglib_file_t file, uint32_t tag_types);
-
- int (*write) (DB_taglib_file_t file);
-
- void (*close) (DB_taglib_file_t file);
-
- void (*set_artist) (DB_taglib_file_t file, const char *txt);
- void (*set_band) (DB_taglib_file_t file, const char *txt);
- void (*set_title) (DB_taglib_file_t file, const char *txt);
- void (*set_track_number) (DB_taglib_file_t file, const char *txt);
- void (*set_album) (DB_taglib_file_t file, const char *txt);
- void (*set_genre) (DB_taglib_file_t file, const char *txt);
- void (*set_year) (DB_taglib_file_t file, const char *txt);
- void (*set_performer) (DB_taglib_file_t file, const char *txt);
- void (*set_composer) (DB_taglib_file_t file, const char *txt);
- void (*set_total_tracks) (DB_taglib_file_t file, const char *txt);
- void (*set_disc_number) (DB_taglib_file_t file, const char *txt);
- void (*set_comment) (DB_taglib_file_t file, const char *txt);
- void (*set_vendor) (DB_taglib_file_t file, const char *txt);
- void (*set_copyright) (DB_taglib_file_t file, const char *txt);
- void (*set_cuesheet) (DB_taglib_file_t file, const char *txt);
- void (*set_replaygain) (DB_taglib_file_t file, const char *txt);
-} DB_taglib_t;
-
-#endif