summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-09-19 12:50:04 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-09-19 14:15:11 +0200
commit864cd9bef0c4dddd1b3287e57a0f07ebb7d3b1dc (patch)
treea653badf62138009e8e7f625e062ab3b6af351a7
parent70ec08354e9472b2bbc549a62f124179aa33d05a (diff)
fixed few tarball issues
-rw-r--r--plugins/adplug/adplug/adplug.h2
-rw-r--r--plugins/adplug/adplug/imf.cpp2
-rw-r--r--plugins/adplug/adplug/player.h2
-rw-r--r--plugins/ao/Makefile.am2
-rw-r--r--plugins/dca/Makefile.am3
-rw-r--r--plugins/gme/Makefile.am3
-rw-r--r--plugins/gtkui/Makefile.am2
-rw-r--r--plugins/mms/mms.c2
-rw-r--r--plugins/musepack/Makefile.am8
-rw-r--r--plugins/shn/Makefile.am2
10 files changed, 17 insertions, 11 deletions
diff --git a/plugins/adplug/adplug/adplug.h b/plugins/adplug/adplug/adplug.h
index f9d2117a..a6373286 100644
--- a/plugins/adplug/adplug/adplug.h
+++ b/plugins/adplug/adplug/adplug.h
@@ -26,7 +26,7 @@
#include "opl.h"
#include "fprovide.h"
#include "players.h"
-#include "database.h"
+//#include "database.h"
class CAdPlug
{
diff --git a/plugins/adplug/adplug/imf.cpp b/plugins/adplug/adplug/imf.cpp
index 06602b9f..4f1716db 100644
--- a/plugins/adplug/adplug/imf.cpp
+++ b/plugins/adplug/adplug/imf.cpp
@@ -45,7 +45,7 @@
#include <stdio.h>
#include "imf.h"
-#include "database.h"
+//#include "database.h"
/*** public methods *************************************/
diff --git a/plugins/adplug/adplug/player.h b/plugins/adplug/adplug/player.h
index c83eda79..171db70c 100644
--- a/plugins/adplug/adplug/player.h
+++ b/plugins/adplug/adplug/player.h
@@ -24,7 +24,7 @@
#include "fprovide.h"
#include "opl.h"
-#include "database.h"
+//#include "database.h"
class CPlayer
{
diff --git a/plugins/ao/Makefile.am b/plugins/ao/Makefile.am
index c332adf4..39ccd749 100644
--- a/plugins/ao/Makefile.am
+++ b/plugins/ao/Makefile.am
@@ -19,6 +19,8 @@ eng_psf/peops2/adsr.h eng_psf/peops2/dma.h eng_psf/peops2/externals.h eng_psf/pe
ao_la_LDFLAGS = -module -fPIC
+EXTRA_DIST=eng_psf/peops/reverb.c eng_psf/peops/adsr.c eng_psf/peops/registers.c eng_psf/peops/dma.c eng_psf/peops2/spu2.c eng_psf/peops2/reverb2.c eng_psf/peops2/adsr2.c eng_dsf/arm7memil.c eng_dsf/aicalfo.c eng_ssf/scsplfo.c
+
ao_la_LIBADD = $(LDADD)
AM_CFLAGS = $(CFLAGS) -Wall -DPATH_MAX=1024 -DHAS_PSXCPU=1 -I.. -Ieng_ssf -Ieng_qsf -Ieng_dsf -lm $(ZLIB_LIBS)
endif
diff --git a/plugins/dca/Makefile.am b/plugins/dca/Makefile.am
index d6429b84..d26d38b2 100644
--- a/plugins/dca/Makefile.am
+++ b/plugins/dca/Makefile.am
@@ -20,7 +20,8 @@ tables_fir.h\
tables.h\
tables_huffman.h\
tables_quantization.h\
-tables_vq.h
+tables_vq.h\
+bitstream.h
dca_la_LDFLAGS = -module
diff --git a/plugins/gme/Makefile.am b/plugins/gme/Makefile.am
index d37a7882..61351f9c 100644
--- a/plugins/gme/Makefile.am
+++ b/plugins/gme/Makefile.am
@@ -109,7 +109,8 @@ game-music-emu-0.5.5/gme/Spc_Emu.h\
game-music-emu-0.5.5/gme/Vgm_Emu.h\
game-music-emu-0.5.5/gme/Vgm_Emu_Impl.h\
game-music-emu-0.5.5/gme/Ym2413_Emu.h\
-game-music-emu-0.5.5/gme/Ym2612_Emu.h
+game-music-emu-0.5.5/gme/Ym2612_Emu.h\
+game-music-emu-0.5.5/gme/gme_types.h
gme_la_LDFLAGS = -module
diff --git a/plugins/gtkui/Makefile.am b/plugins/gtkui/Makefile.am
index ad48aca7..609917ed 100644
--- a/plugins/gtkui/Makefile.am
+++ b/plugins/gtkui/Makefile.am
@@ -39,7 +39,7 @@ gtkui_la_LDFLAGS = -module
gtkui_la_LIBADD = $(LDADD) $(GTKUI_DEPS_LIBS) $(NOTIFY_DEPS_LIBS)
AM_CFLAGS = -std=c99 $(GTKUI_DEPS_CFLAGS) $(NOTIFY_DEPS_CFLAGS)
-EXTRA_DIST = $(gtkui_VALASOURCES)
+EXTRA_DIST = $(gtkui_VALASOURCES) deadbeef.glade
if MAINTAINER_MODE
CLEANFILES = \
diff --git a/plugins/mms/mms.c b/plugins/mms/mms.c
index 617b16f2..4ad57832 100644
--- a/plugins/mms/mms.c
+++ b/plugins/mms/mms.c
@@ -16,7 +16,7 @@
along with this program; if not, write to the Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
*/
-#include "deadbeef.h"
+#include "../../deadbeef.h"
#include <stdio.h>
#include <stdlib.h>
#include <assert.h>
diff --git a/plugins/musepack/Makefile.am b/plugins/musepack/Makefile.am
index 496f1468..ae53b6e5 100644
--- a/plugins/musepack/Makefile.am
+++ b/plugins/musepack/Makefile.am
@@ -16,11 +16,13 @@ decoder.h\
huffman.h\
internal.h\
mpc_bits_reader.h\
-mpcdec.h\
+mpc/mpcdec.h\
mpcdec_math.h\
-reader.h\
+mpc/reader.h\
requant.h\
-streaminfo.h
+mpc/streaminfo.h\
+mpc/mpc_types.h\
+mpc/minimax.h
musepack_la_LDFLAGS = -module
diff --git a/plugins/shn/Makefile.am b/plugins/shn/Makefile.am
index 44671140..53d8c26b 100644
--- a/plugins/shn/Makefile.am
+++ b/plugins/shn/Makefile.am
@@ -1,7 +1,7 @@
if HAVE_SHN
shndir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = shn.la
-shn_la_SOURCES = array.c config.h convert.c misc.c output.c seek.c shn.c shn.h shorten.c shorten.h sulawalaw.c vario.c wave.c
+shn_la_SOURCES = array.c convert.c misc.c output.c seek.c shn.c shn.h shorten.c shorten.h sulawalaw.c vario.c wave.c bitshift.h
shn_la_LDFLAGS = -module