summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2010-11-07 13:50:03 +0100
committerGravatar waker <wakeroid@gmail.com>2010-11-07 13:50:03 +0100
commit77b9ae5b8fc81fddb0d7c5ca455e8b0b56399909 (patch)
tree8895374a21124d7e79e6ec1781ec55e76da479ce
parent872a8a37dbe7e363de581bd070159150b132ceda (diff)
bumped ffmpeg-plugin to 1.1, linked with ffmpeg 25472 to fix issues with some wma streams
-rw-r--r--configure.ac3
-rw-r--r--lib-x86-32/libavcodec.abin4498534 -> 4456812 bytes
-rw-r--r--lib-x86-32/libavcore.abin0 -> 42030 bytes
-rw-r--r--lib-x86-32/libavformat.abin1003762 -> 1208954 bytes
-rw-r--r--lib-x86-32/libavutil.abin298106 -> 407860 bytes
-rw-r--r--plugins/ffmpeg/ChangeLog2
-rw-r--r--plugins/ffmpeg/ffmpeg.c2
7 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a486023d..2a364423 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,9 +131,8 @@ if test "x$enable_alsa" != "xno" ; then
fi
if test "x$enable_ffmpeg" != "xno" ; then
-echo "ffmpeg build is enabled"
if test "x$enable_portable" != "xno" ; then
- FFMPEG_DEPS_LIBS="../../$LIB/libavcodec.a -lpthread ../../$LIB/libavformat.a ../../$LIB/libavcodec.a ../../$LIB/libavutil.a -lm ../../$LIB/libz.a "
+ FFMPEG_DEPS_LIBS="../../$LIB/libavcodec.a -lpthread ../../$LIB/libavformat.a ../../$LIB/libavcodec.a ../../$LIB/libavutil.a ../../$LIB/libavcore.a -lm ../../$LIB/libz.a "
AC_SUBST(FFMPEG_DEPS_LIBS)
HAVE_FFMPEG=yes
else
diff --git a/lib-x86-32/libavcodec.a b/lib-x86-32/libavcodec.a
index 9abf8d1e..4e670cbc 100644
--- a/lib-x86-32/libavcodec.a
+++ b/lib-x86-32/libavcodec.a
Binary files differ
diff --git a/lib-x86-32/libavcore.a b/lib-x86-32/libavcore.a
new file mode 100644
index 00000000..475ffffb
--- /dev/null
+++ b/lib-x86-32/libavcore.a
Binary files differ
diff --git a/lib-x86-32/libavformat.a b/lib-x86-32/libavformat.a
index 85cac092..58dd2ab9 100644
--- a/lib-x86-32/libavformat.a
+++ b/lib-x86-32/libavformat.a
Binary files differ
diff --git a/lib-x86-32/libavutil.a b/lib-x86-32/libavutil.a
index 9456d655..c565f3d1 100644
--- a/lib-x86-32/libavutil.a
+++ b/lib-x86-32/libavutil.a
Binary files differ
diff --git a/plugins/ffmpeg/ChangeLog b/plugins/ffmpeg/ChangeLog
new file mode 100644
index 00000000..a3edb5f1
--- /dev/null
+++ b/plugins/ffmpeg/ChangeLog
@@ -0,0 +1,2 @@
+version 1.1
+ Switched to ffmpeg commit 25472
diff --git a/plugins/ffmpeg/ffmpeg.c b/plugins/ffmpeg/ffmpeg.c
index 3433889c..498f0332 100644
--- a/plugins/ffmpeg/ffmpeg.c
+++ b/plugins/ffmpeg/ffmpeg.c
@@ -715,7 +715,7 @@ ffmpeg_read_metadata (DB_playItem_t *it) {
static DB_decoder_t plugin = {
DB_PLUGIN_SET_API_VERSION
.plugin.version_major = 1,
- .plugin.version_minor = 0,
+ .plugin.version_minor = 1,
.plugin.type = DB_PLUGIN_DECODER,
.plugin.id = "ffmpeg",
.plugin.name = "FFMPEG audio player",