summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-13 20:58:30 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-13 20:58:30 +0200
commit727c0b1acdf014b873ae5ec7a3c33a8145f4a172 (patch)
tree7a9fe20669ad41f8eb9e4509c57be31dc99c26f3
parent5644e30666647b94f75f86607e945c3b263ba73b (diff)
version bump to 0.2.2
-rw-r--r--ChangeLog10
-rw-r--r--PKGBUILD6
-rw-r--r--configure.in2
-rw-r--r--icons/Makefile.am10
-rw-r--r--web/index.html24
5 files changed, 42 insertions, 10 deletions
diff --git a/ChangeLog b/ChangeLog
index 9a409b14..4583b3b7 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,13 @@
+version 0.2.2
+ fixed several build problems reported by users
+ added app icons, updated launcher script
+ proper sse2 detection and usage in ape plugin
+ reduced volumebar range to -50dB
+ horizontal scrolling in playlist
+ pango is now used for ellipsizing
+ case-insensitive search using russian, danish, french and other alphabets
+ vertical scroll is much faster now
+
version 0.2.1
new ape decoder - faster, doesn't crash
fixed APEv2 tag reader
diff --git a/PKGBUILD b/PKGBUILD
index 5f71307b..b6eebb50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Alexey Yakovenko <waker@users.sourceforge.net>
pkgname=deadbeef
-pkgver=0.2.1
-pkgrel=1
+pkgver=0.2.2
+pkgrel=2
pkgdesc="mp3/ogg/flac/ape/sid/mod/nsf music player based on GTK2"
arch=(i686 x86_64)
url="http://deadbeef.sourceforge.net"
@@ -12,7 +12,7 @@ depends=('gtk2' 'libsamplerate' 'alsa-lib')
optdepends=('libvorbis: ogg vorbis playback', 'libmad: mp1/2/3 playback', 'flac: flac playback', 'curl: lastfm scrobbler')
makedepends=('pkgconfig')
source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('5b9de8962d77eea2748208d9ed563952')
+md5sums=('62f745ed00ed835530b9ffc9b7e89df2')
build() {
cd $srcdir/$pkgname-$pkgver
diff --git a/configure.in b/configure.in
index 2d581f58..b312cfe2 100644
--- a/configure.in
+++ b/configure.in
@@ -3,7 +3,7 @@ AC_INIT
AC_CONFIG_HEADER(config.h)
PACKAGE="deadbeef"
-VERSION="0.2.2-dev"
+VERSION="0.2.2"
AM_INIT_AUTOMAKE($PACKAGE,$VERSION)
diff --git a/icons/Makefile.am b/icons/Makefile.am
index e540a82a..68bec9c7 100644
--- a/icons/Makefile.am
+++ b/icons/Makefile.am
@@ -1,10 +1,12 @@
+iconspath=@top_srcdir@/icons
+
icon16dir=$(prefix)/share/icons/hicolor/16x16/apps
-icon16_DATA=16x16/deadbeef.png
+icon16_DATA=$(iconspath)/16x16/deadbeef.png
icon32dir=$(prefix)/share/icons/hicolor/32x32/apps
-icon32_DATA=32x32/deadbeef.png
+icon32_DATA=$(iconspath)/32x32/deadbeef.png
icon48dir=$(prefix)/share/icons/hicolor/48x48/apps
-icon48_DATA=48x48/deadbeef.png
+icon48_DATA=$(iconspath)/48x48/deadbeef.png
-EXTRADIST = $(icon16_DATA) $(icon32_DATA) $(icon48_DATA)
+EXTRA_DIST = $(icon16_DATA) $(icon32_DATA) $(icon48_DATA)
diff --git a/web/index.html b/web/index.html
index 1550372c..305aa536 100644
--- a/web/index.html
+++ b/web/index.html
@@ -49,6 +49,24 @@
<h1 id="news">News</h1>
+
+<h2>release 0.2.2 is out</h2>
+<div class="post">
+ <p class="date">2009/09/13</p>
+ <p><a href="#download">get it!</a></p>
+ <p>Changelog since 0.2.1</p>
+ <ul>
+ <li>fixed several build problems reported by users</li>
+ <li>added app icons, updated launcher script</li>
+ <li>proper sse2 detection and usage in ape plugin</li>
+ <li>reduced volumebar range to -50dB</li>
+ <li>horizontal scrolling in playlist</li>
+ <li>pango is now used for ellipsizing</li>
+ <li>case-insensitive search using russian, danish, french and other alphabets</li>
+ <li>vertical scroll is much faster now</li>
+ </ul>
+</div>
+
<h2>release 0.2.1 is out</h2>
<div class="post">
<p class="date">2009/09/12</p>
@@ -248,11 +266,13 @@ implemented basic session management, window size/position, volume, playmode are
</pre>
<h1 id="download">Download</h1>
-<h2>Latest version:</h2>
+<h2>Latest version 0.2.2:</h2>
<p>official Arch Linux PKGBUILD: <a href="http://aur.archlinux.org/packages.php?ID=29497">here</a></p>
<p>if you have yaourt, you can simply do yaourt -S deadbeef</p>
-<p>source code for version 0.2.1 <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.2.1.tar.gz/download">deadbeef-0.2.1.tar.gz</a></p>
+<p>source code for version 0.2.2 <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.2.2.tar.gz/download">deadbeef-0.2.2.tar.gz</a></p>
<p>or <a href="http://sourceforge.net/projects/deadbeef/files/">browse all files</a></p>
+<h2>version 0.2.1:</h2>
+<p>source code for version 0.2.1 <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.2.1.tar.gz/download">deadbeef-0.2.1.tar.gz</a></p>
<h2>version 0.2.0:</h2>
<p>source code for version 0.2.0 <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.2.0.tar.gz/download">deadbeef-0.2.0.tar.gz</a></p>
<p><b>unsupported</b> slackware package for version 0.2.0 from <a href="mailto:sftp.mtuci@gmail.com">sftp.mtuci@gmail.com</a>:</p>