summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-06-03 09:26:02 +0200
committerGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-06-03 09:26:02 +0200
commit62da2bfeb1e8a1c85cf9e562ca497abc4d8cd109 (patch)
tree151d17b1eab179ded70cbb8c4d998a90ea45794f
parent34f6c4fba38d7fa6b222d7e33869ca3b203ed45e (diff)
liboggedit: fixed makefile and added the output to .gitignore
-rw-r--r--.gitignore1
-rw-r--r--plugins/liboggedit/Makefile.am4
2 files changed, 4 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index 523da8a0..6fdc178b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -74,6 +74,7 @@ messages.mo
.config
plugins/libmp4ff/libmp4ff.a
plugins/libparser/libparser.a
+plugins/liboggedit/liboggedit.a
testrun.sh
tools/pluginfo/i686
tools/pluginfo/x86_64
diff --git a/plugins/liboggedit/Makefile.am b/plugins/liboggedit/Makefile.am
index 585c7f29..cdf59124 100644
--- a/plugins/liboggedit/Makefile.am
+++ b/plugins/liboggedit/Makefile.am
@@ -1,3 +1,5 @@
+if HAVE_VORBIS
noinst_LIBRARIES = liboggedit.a
liboggedit_a_SOURCES = oggedit.c
-AM_CFLAGS = -fPIC -std=c99 \ No newline at end of file
+AM_CFLAGS = $(VORBIS_CFLAGS) -fPIC -std=c99
+endif