summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-02-02 21:37:42 +0100
committerGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-02-02 21:37:42 +0100
commit605df291ca7391a6ee1c05ac3dd8d98498fdcd98 (patch)
tree0359de9e96848eb25c22e1be243f53523e938182
parentf796db21cfb110ce413137890e2155d2991d7fc3 (diff)
0.6.1
-rw-r--r--ChangeLog2
-rw-r--r--PORTABLE_VERSION2
-rw-r--r--configure.ac2
-rwxr-xr-xtools/packages/arch.sh11
-rwxr-xr-xtools/packages/debian.sh17
5 files changed, 21 insertions, 13 deletions
diff --git a/ChangeLog b/ChangeLog
index 69218978..18115d2c 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -33,6 +33,8 @@ version 0.6.1
prevent passing non-utf8 filenames to progress dialog
fixed crash when opening invalid VTX files
fixed crash when opening invalid WMA files
+ don't delete replaygain info from FLACs when writing tags
+ fixed really old buffer overflow bug in dnd handler (kudos to Megabaks)
version 0.6.0
gui layout designer, with a set of widgets to choose from (View -> Design mode, then use right click)
diff --git a/PORTABLE_VERSION b/PORTABLE_VERSION
index d64531f1..ee6cdce3 100644
--- a/PORTABLE_VERSION
+++ b/PORTABLE_VERSION
@@ -1 +1 @@
-devel
+0.6.1
diff --git a/configure.ac b/configure.ac
index 4908486c..7695f889 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([deadbeef], [devel])
+AC_INIT([deadbeef], [0.6.1])
AC_CONFIG_HEADER(config.h)
diff --git a/tools/packages/arch.sh b/tools/packages/arch.sh
index 47f54a8e..8f2e5c3e 100755
--- a/tools/packages/arch.sh
+++ b/tools/packages/arch.sh
@@ -1,10 +1,17 @@
-#!/bin/sh
+#!/bin/bash
PWD=`pwd`
VERSION=`cat PORTABLE_VERSION | perl -ne 'chomp and print'`
ARCH_VERSION=`cat PORTABLE_VERSION | perl -ne 'chomp and print' | sed 's/-//'`
BUILD=`cat PORTABLE_BUILD | perl -ne 'chomp and print'`
-ARCH=`uname -m | perl -ne 'chomp and print'`
+if [[ "$ARCH" == "i686" ]]; then
+ echo
+elif [[ "$ARCH" == "x86_64" ]]; then
+ echo
+else
+ echo unknown arch $ARCH
+ exit -1
+fi
INDIR=$PWD/static/$ARCH/deadbeef-$VERSION
TEMPDIR=$PWD/package_temp/$ARCH/arch-$VERSION
PKGINFO=$TEMPDIR/.PKGINFO
diff --git a/tools/packages/debian.sh b/tools/packages/debian.sh
index 58d02602..d4c1e5d9 100755
--- a/tools/packages/debian.sh
+++ b/tools/packages/debian.sh
@@ -1,21 +1,20 @@
-#!/bin/sh
+#!/bin/bash
PWD=`pwd`
VERSION=`cat PORTABLE_VERSION | perl -ne 'chomp and print'`
DEB_VERSION=`cat PORTABLE_VERSION | perl -ne 'chomp and print' | sed 's/-/~/'`
BUILD=`cat PORTABLE_BUILD | perl -ne 'chomp and print'`
-ARCH=`uname -m | perl -ne 'chomp and print'`
-INDIR=$PWD/static/$ARCH/deadbeef-$VERSION
-TEMPDIR=$PWD/package_temp/$ARCH/debian-$VERSION
-OUTDIR=$PWD/package_out/$ARCH/debian
-
-if [ "$ARCH" = "i686" ] ; then
+if [[ "$ARCH" == "i686" ]]; then
DEB_ARCH=i386
-elif [ "$ARCH" = "x86_64" ] ; then
+elif [[ "$ARCH" == "x86_64" ]]; then
DEB_ARCH=amd64
else
- DEB_ARCH=unknown
+ echo unknown arch $ARCH
+ exit -1
fi
+INDIR=$PWD/static/$ARCH/deadbeef-$VERSION
+TEMPDIR=$PWD/package_temp/$ARCH/debian-$VERSION
+OUTDIR=$PWD/package_out/$ARCH/debian
# make dirs
rm -rf $TEMPDIR