summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <waker@users.sourceforge.net>2013-08-29 20:28:09 +0200
committerGravatar Alexey Yakovenko <waker@users.sourceforge.net>2013-08-29 20:28:09 +0200
commit3ad91661619b579076f32ce6c1727c3eb176adde (patch)
treef2b9cf83273f846826d3d1e7d2a096edf9af0be3
parentae2eb9c875aa603d3b9a72aabef955ef8d5ff711 (diff)
adplug and gme copile fixes
-rw-r--r--plugins/adplug/Makefile.am2
-rw-r--r--plugins/gme/Makefile.am2
-rw-r--r--plugins/gme/game-music-emu-0.6pre/gme/fmopl.cpp2
-rw-r--r--plugins/gme/game-music-emu-0.6pre/gme/ym2413.c4
4 files changed, 5 insertions, 5 deletions
diff --git a/plugins/adplug/Makefile.am b/plugins/adplug/Makefile.am
index 6a56e1b8..471cb3cd 100644
--- a/plugins/adplug/Makefile.am
+++ b/plugins/adplug/Makefile.am
@@ -5,7 +5,7 @@ adlibdir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = adplug.la
AM_CFLAGS = $(CFLAGS) -std=c99 -I$(adplugpath)/adplug -I$(adplugpath)/libbinio -fPIC
-adplug_la_LDFLAGS = -module -nostdlib -lm -lsupc++
+adplug_la_LDFLAGS = -module -lm $(NOCPPLIB)
AM_CPPFLAGS = $(CXXFLAGS) -Dstricmp=strcasecmp -DVERSION=\"2.1\" -I$(adplugpath)/adplug -I$(adplugpath)/libbinio -fno-exceptions -fno-rtti -fno-unwind-tables
diff --git a/plugins/gme/Makefile.am b/plugins/gme/Makefile.am
index cc506737..9c789c38 100644
--- a/plugins/gme/Makefile.am
+++ b/plugins/gme/Makefile.am
@@ -398,7 +398,7 @@ gme_la_SOURCES = cgme.c\
# $(gmeversion)/gme/Spc_Filter.cpp\
# $(gmeversion)/gme/Spc_Filter.h
-gme_la_LDFLAGS = -module -nostdlib -lsupc++
+gme_la_LDFLAGS = -module $(NOCPPLIB)
gme_la_LIBADD = $(ZLIB_LIBS)
AM_CFLAGS = $(CFLAGS) $(ZLIB_CFLAGS) -I$(gmepath) -std=c99 -DGME_VERSION_055
diff --git a/plugins/gme/game-music-emu-0.6pre/gme/fmopl.cpp b/plugins/gme/game-music-emu-0.6pre/gme/fmopl.cpp
index 9ec1dd46..2f101e4c 100644
--- a/plugins/gme/game-music-emu-0.6pre/gme/fmopl.cpp
+++ b/plugins/gme/game-music-emu-0.6pre/gme/fmopl.cpp
@@ -1354,7 +1354,7 @@ INLINE void FM_KEYOFF(OPL_SLOT *SLOT, UINT32 key_clr)
}
/* update phase increment counter of operator (also update the EG rates if necessary) */
-INLINE void CALC_FCSLOT(OPL_CH *CH,OPL_SLOT *SLOT)
+static INLINE void CALC_FCSLOT(OPL_CH *CH,OPL_SLOT *SLOT)
{
int ksr;
diff --git a/plugins/gme/game-music-emu-0.6pre/gme/ym2413.c b/plugins/gme/game-music-emu-0.6pre/gme/ym2413.c
index edb7354b..28d6991f 100644
--- a/plugins/gme/game-music-emu-0.6pre/gme/ym2413.c
+++ b/plugins/gme/game-music-emu-0.6pre/gme/ym2413.c
@@ -43,7 +43,7 @@ to do:
#include <string.h>
#include "ym2413.h"
-#define INLINE __inline
+#define INLINE static __inline
#ifndef NULL
#define NULL ((void *)0)
#endif
@@ -2103,4 +2103,4 @@ void ym2413_set_mask(void *_chip, UINT32 mask)
YM2413 *chip = (YM2413 *)_chip;
chip->mask = mask;
-} \ No newline at end of file
+}