summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2011-04-30 22:45:25 +0200
committerGravatar waker <wakeroid@gmail.com>2011-04-30 22:45:25 +0200
commit38670c492e60b6f6a2d826b2057dc9dd27a90f9b (patch)
tree9e4ca0f25f851a045fe111e71394724f6845ddee
parent85fd12a315d55de041ac3b5ef1ef22c27715bd65 (diff)
fixed compiling with apgcc; fixed compiling converter gui fallback
-rw-r--r--plugins/converter/Makefile.am2
-rwxr-xr-xscripts/portable_build.sh4
-rwxr-xr-xscripts/portable_package_static.sh1
-rwxr-xr-xscripts/portable_postbuild.sh3
4 files changed, 7 insertions, 3 deletions
diff --git a/plugins/converter/Makefile.am b/plugins/converter/Makefile.am
index 198cec95..b0c56d32 100644
--- a/plugins/converter/Makefile.am
+++ b/plugins/converter/Makefile.am
@@ -1,7 +1,7 @@
if HAVE_CONVERTER
if STATICLINK
-pkglib_LTLIBRARIES = converter.la converter_gtkui.la converter_gtkui_fallback.la
+pkglib_LTLIBRARIES = converter.la converter_gtkui.la converter_gtkui.fallback.la
else
pkglib_LTLIBRARIES = converter.la converter_gtkui.la
endif
diff --git a/scripts/portable_build.sh b/scripts/portable_build.sh
index 5ab23f29..412db5fa 100755
--- a/scripts/portable_build.sh
+++ b/scripts/portable_build.sh
@@ -4,8 +4,8 @@ ORIGIN=`pwd | perl -ne 'chomp and print'`
export APBUILD_STATIC_LIBGCC=1
./autogen.sh
-CC=$ORIGIN/tools/apbuild/apgcc
-CXX=$ORIGIN/tools/apbuild/apgcc
+export CC=$ORIGIN/tools/apbuild/apgcc
+export CXX=$ORIGIN/tools/apbuild/apgcc
./configure --enable-staticlink --enable-portable --disable-nls --disable-artwork-imlib2
sed -i 's/-lstdc++ -lm -lgcc_s -lc -lgcc_s/-lm -lc/g' libtool
diff --git a/scripts/portable_package_static.sh b/scripts/portable_package_static.sh
index 0ad8752a..22cb0a47 100755
--- a/scripts/portable_package_static.sh
+++ b/scripts/portable_package_static.sh
@@ -54,6 +54,7 @@ tar jcvf ../portable_out/build/deadbeef-$VERSION-static-i686.tar.bz2\
$PLUGDIR/dumb.so\
$PLUGDIR/converter.so\
$PLUGDIR/converter_gtkui.so\
+ $PLUGDIR/converter_gtkui.fallback.so\
$PLUGDIR/pulse.so\
$PLUGDIR/dsp_libsrc.so\
$PIXMAPDIR
diff --git a/scripts/portable_postbuild.sh b/scripts/portable_postbuild.sh
index 9fd9bded..0ed1a186 100755
--- a/scripts/portable_postbuild.sh
+++ b/scripts/portable_postbuild.sh
@@ -45,6 +45,9 @@ fi
if [ -f ./plugins/gtkui/.libs/ddb_gui_GTK2.fallback.so ]; then
cp ./plugins/gtkui/.libs/ddb_gui_GTK2.fallback.so $PLUGDIR/
fi
+if [ -f ./plugins/converter/.libs/converter_gtkui.fallback.so ]; then
+ cp ./plugins/converter/.libs/converter_gtkui.fallback.so $PLUGDIR/
+fi
#pixmaps