summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@mit.edu>2015-01-19 21:19:05 -0500
committerGravatar Benjamin Barenblat <bbaren@mit.edu>2015-01-20 15:40:33 -0500
commit3300069a93f3c617f63742dede3e7deb7036c82e (patch)
treee41838f39ff94968148b8e7a86cd79a5cad9b527
parent43422fe3879239caf172cbb6709c2dd5d9f0d721 (diff)
Enable AAC plugin
-rw-r--r--debian/control1
-rw-r--r--debian/deadbeef.lintian-overrides1
-rw-r--r--debian/patches/mp4ff-spelling-psychedelic.diff26
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules2
5 files changed, 30 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 4cd0ee19..4eb76ac3 100644
--- a/debian/control
+++ b/debian/control
@@ -12,6 +12,7 @@ Build-Depends:
libcdio-dev,
libcurl4-gnutls-dev (>= 7.10) | libcurl-dev (>= 7.10),
libdbus-1-dev,
+ libfaad-dev,
libflac-dev,
libgtk2.0-dev (>= 2.12),
libgtk-3-dev,
diff --git a/debian/deadbeef.lintian-overrides b/debian/deadbeef.lintian-overrides
index 818f8299..c22a053f 100644
--- a/debian/deadbeef.lintian-overrides
+++ b/debian/deadbeef.lintian-overrides
@@ -1 +1,2 @@
deadbeef: spelling-error-in-binary usr/bin/deadbeef Psychadelic Psychedelic
+deadbeef: spelling-error-in-binary usr/lib/x86_64-linux-gnu/deadbeef/aac.so Psychadelic Psychedelic
diff --git a/debian/patches/mp4ff-spelling-psychedelic.diff b/debian/patches/mp4ff-spelling-psychedelic.diff
new file mode 100644
index 00000000..d67c1e0a
--- /dev/null
+++ b/debian/patches/mp4ff-spelling-psychedelic.diff
@@ -0,0 +1,26 @@
+From: Benjamin Barenblat <bbaren@mit.edu>
+Description: mp4meta: use Psychedelic instead of Psychadelic
+ The ID3v1 standard misspells ‘psychedelic’ as ‘psychadelic’. This patch hides
+ this from the user.
+Forwarded: no
+Last-Update: 2015-01-19
+--- a/plugins/libmp4ff/mp4meta.c
++++ b/plugins/libmp4ff/mp4meta.c
+@@ -115,7 +115,7 @@ static const char* ID3v1GenreList[] = {
+ "Ethnic", "Gothic", "Darkwave", "Techno-Industrial", "Electronic", "Pop-Folk",
+ "Eurodance", "Dream", "Southern Rock", "Comedy", "Cult", "Gangsta",
+ "Top 40", "Christian Rap", "Pop/Funk", "Jungle", "Native American", "Cabaret",
+- "New Wave", "Psychadelic", "Rave", "Showtunes", "Trailer", "Lo-Fi",
++ "New Wave", "Psychedelic", "Rave", "Showtunes", "Trailer", "Lo-Fi",
+ "Tribal", "Acid Punk", "Acid Jazz", "Polka", "Retro", "Musical",
+ "Rock & Roll", "Hard Rock", "Folk", "Folk/Rock", "National Folk", "Swing",
+ "Fast-Fusion", "Bebob", "Latin", "Revival", "Celtic", "Bluegrass", "Avantgarde",
+@@ -135,6 +135,8 @@ static const char* ID3v1GenreList[] = {
+ uint32_t mp4ff_meta_genre_to_index(const char * genrestr)
+ {
+ unsigned n;
++ /* workaround for the id3v1 std spelling error */
++ if(!stricmp(genrestr,"Psychadelic")) return 68;
+ for(n=0;n<sizeof(ID3v1GenreList)/sizeof(ID3v1GenreList[0]);n++)
+ {
+ if (!stricmp(genrestr,ID3v1GenreList[n])) return n+1;
diff --git a/debian/patches/series b/debian/patches/series
index 724868f6..e476505e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,5 +1,6 @@
remove-interfering-maintainer-files.diff
junklib-spelling-psychedelic.diff
+mp4ff-spelling-psychedelic.diff
gtkui-grammar-allows-setting.diff
gtkui-grammar-allows-setting-2.diff
desktop-keywords.diff
diff --git a/debian/rules b/debian/rules
index e4b40f37..2ad7c460 100755
--- a/debian/rules
+++ b/debian/rules
@@ -45,7 +45,7 @@ override_dh_auto_configure:
--disable-wildmidi \
--disable-tta \
--disable-dca \
- --disable-aac \
+ --enable-aac \
--disable-mms \
--disable-staticlink \
--disable-src \