summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2010-12-04 15:46:15 +0100
committerGravatar waker <wakeroid@gmail.com>2010-12-04 15:46:15 +0100
commit03028aa3c329a3da52e382c00eff2d978f9fd3ef (patch)
treebdebd55751dd589cd444c2c59dde960b83b53e17
parentd370f8648a90893914e0c9dc2a4fcf05dd1bd257 (diff)
removed DUMB plugin from tarball
-rw-r--r--configure.ac10
-rw-r--r--plugins/dumb/Makefile (renamed from plugins/dumb/Makefile.am)53
2 files changed, 22 insertions, 41 deletions
diff --git a/configure.ac b/configure.ac
index 193ec54a..9c6daa3c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,7 +94,6 @@ AC_ARG_ENABLE(sndfile, [AS_HELP_STRING([--disable-sndfile ], [disable libsndfil
AC_ARG_ENABLE(wavpack, [AS_HELP_STRING([--disable-wavpack ], [disable wavpack plugin (default: enabled)])], [enable_wavpack=$enableval], [enable_wavpack=yes])
AC_ARG_ENABLE(cdda, [AS_HELP_STRING([--disable-cdda ], [disable CD-Audio plugin (default: enabled)])], [enable_cdda=$enableval], [enable_cdda=yes])
AC_ARG_ENABLE(gme, [AS_HELP_STRING([--disable-gme ], [disable Game Music Emu plugin for NSF, AY, etc (default: enabled)])], [enable_gme=$enableval], [enable_gme=yes])
-AC_ARG_ENABLE(dumb, [AS_HELP_STRING([--disable-dumb ], [disable D.U.M.B. plugin for MOD, S3M and other tracker formats (default: enabled)])], [enable_dumb=$enableval], [enable_dumb=yes])
AC_ARG_ENABLE(notify, [AS_HELP_STRING([--disable-notify ], [disable notification-daemon support plugin (default: enabled)])], [enable_notify=$enableval], [enable_notify=yes])
AC_ARG_ENABLE(shellexec, [AS_HELP_STRING([--disable-shellexec], [disable shell commands plugin (default: enabled)])], [enable_shellexec=$enableval], [enable_shellexec=yes])
AC_ARG_ENABLE(musepack, [AS_HELP_STRING([--disable-musepack], [disable musepack plugin (default: enabled)])], [enable_musepack=$enableval], [enable_musepack=yes])
@@ -439,10 +438,6 @@ if test "x$enable_gme" != "xno" ; then
HAVE_GME=yes
fi
-if test "x$enable_dumb" != "xno" ; then
- HAVE_DUMB=yes
-fi
-
if test "x$HAVE_DBUS" = "xyes" && test "x$enable_notify" != "xno" ; then
HAVE_NOTIFY=yes
NOTIFY_LIBS="$DBUS_DEPS_LIBS"
@@ -496,7 +491,7 @@ if test "x$enable_m3u" != "xno" ; then
HAVE_M3U=yes
fi
-PLUGINS_DIRS="plugins/lastfm plugins/mpgmad plugins/vorbis plugins/flac plugins/wavpack plugins/sndfile plugins/vfs_curl plugins/cdda plugins/gtkui plugins/alsa plugins/ffmpeg plugins/hotkeys plugins/oss plugins/artwork plugins/adplug plugins/ffap plugins/sid plugins/nullout plugins/supereq plugins/vtx plugins/gme plugins/dumb plugins/pulse plugins/notify plugins/musepack plugins/wildmidi plugins/tta plugins/dca plugins/aac plugins/mms plugins/shn plugins/shellexec plugins/dsp_libsrc plugins/m3u"
+PLUGINS_DIRS="plugins/lastfm plugins/mpgmad plugins/vorbis plugins/flac plugins/wavpack plugins/sndfile plugins/vfs_curl plugins/cdda plugins/gtkui plugins/alsa plugins/ffmpeg plugins/hotkeys plugins/oss plugins/artwork plugins/adplug plugins/ffap plugins/sid plugins/nullout plugins/supereq plugins/vtx plugins/gme plugins/pulse plugins/notify plugins/musepack plugins/wildmidi plugins/tta plugins/dca plugins/aac plugins/mms plugins/shn plugins/shellexec plugins/dsp_libsrc plugins/m3u"
AM_CONDITIONAL(HAVE_VORBIS, test "x$HAVE_VORBISPLUGIN" = "xyes")
AM_CONDITIONAL(HAVE_FLAC, test "x$HAVE_FLACPLUGIN" = "xyes")
@@ -514,7 +509,6 @@ AM_CONDITIONAL(HAVE_SID, test "x$HAVE_SID" = "xyes")
AM_CONDITIONAL(HAVE_NULLOUT, test "x$HAVE_NULLOUT" = "xyes")
AM_CONDITIONAL(HAVE_VTX, test "x$HAVE_VTX" = "xyes")
AM_CONDITIONAL(HAVE_GME, test "x$HAVE_GME" = "xyes")
-AM_CONDITIONAL(HAVE_DUMB, test "x$HAVE_DUMB" = "xyes")
AM_CONDITIONAL(HAVE_LASTFM, test "x$HAVE_LASTFM" = "xyes")
AM_CONDITIONAL(HAVE_VFS_CURL, test "x$HAVE_VFS_CURL" = "xyes")
AM_CONDITIONAL(HAVE_HOTKEYS, test "x$HAVE_HOTKEYS" = "xyes")
@@ -563,7 +557,6 @@ AC_DEFUN([PRINT_PLUGIN_INFO],
PRINT_PLUGIN_INFO([stdio],[Standard IO plugin],[true])
PRINT_PLUGIN_INFO([gme],[chiptune music player based on GME],[test "x$HAVE_GME" = "xyes"])
-PRINT_PLUGIN_INFO([dumb],[module player based on DUMB library],[test "x$HAVE_DUMB" = "xyes"])
PRINT_PLUGIN_INFO([nullout],[NULL output],[test "x$HAVE_NULLOUT" = "xyes"])
PRINT_PLUGIN_INFO([alsa],[ALSA output],[test "x$HAVE_ALSA" = "xyes"])
PRINT_PLUGIN_INFO([sid],[SID player based on libsidplay2],[test "x$HAVE_SID" = "xyes"])
@@ -604,7 +597,6 @@ Makefile
pixmaps/Makefile
icons/Makefile
plugins/gme/Makefile
-plugins/dumb/Makefile
plugins/alsa/Makefile
plugins/hotkeys/Makefile
plugins/lastfm/Makefile
diff --git a/plugins/dumb/Makefile.am b/plugins/dumb/Makefile
index f3bb7f46..0e983a56 100644
--- a/plugins/dumb/Makefile.am
+++ b/plugins/dumb/Makefile
@@ -1,14 +1,12 @@
-if HAVE_DUMB
-dumbpath=@top_srcdir@/plugins/dumb/dumb-kode54
+CC=gcc
-EXTRA_DIST = $(dumbpath)/readme.txt $(dumbpath)/ChangeLog $(dumbpath)/licence.txt $(dumbpath)/release.txt $(dumbpath)/todo.txt
+dumbpath=dumb-kode54
-pkglib_LTLIBRARIES = dumb.la
+CFLAGS=-Wall -I$(dumbpath)/include -std=c99
-AM_CFLAGS = $(CFLAGS) -I$(dumbpath)/include -std=c99
-dumb_la_LDFLAGS = -module -lm
+LDFLAGS=-module -shared -fPIC -lm
-dumb_la_SOURCES =\
+SOURCES=\
dumb-kode54/src/it/readam.c\
dumb-kode54/src/it/readstm.c\
dumb-kode54/src/it/loads3m.c\
@@ -79,29 +77,20 @@ dumb-kode54/src/helpers/riff.c\
dumb-kode54/src/helpers/memfile.c\
dumb-kode54/src/helpers/sampbuf.c\
dumb-kode54/src/helpers/barray.c\
-dumb-kode54/studio/include/guitop.h\
-dumb-kode54/studio/include/dumbgui.h\
-dumb-kode54/studio/include/options.h\
-dumb-kode54/studio/include/subclip.h\
-dumb-kode54/studio/include/main.h\
-dumb-kode54/studio/include/guiproc.h\
-dumb-kode54/studio/include/dumbmenu.h\
-dumb-kode54/studio/include/dumbdesk.h\
-dumb-kode54/src/tools/it/modulus.h\
-dumb-kode54/include/internal/it.h\
-dumb-kode54/include/internal/dumb.h\
-dumb-kode54/include/internal/barray.h\
-dumb-kode54/include/internal/riff.h\
-dumb-kode54/include/internal/aldumb.h\
-dumb-kode54/include/dumb.h\
-dumb-kode54/include/aldumb.h\
-dumb-kode54/winamp/in_duh.h\
-dumb-kode54/winamp/in2.h\
-dumb-kode54/winamp/resource.h\
-dumb-kode54/winamp/out.h\
-dumb-kode54/winamp/gui.h\
-dumb-kode54/src/helpers/resample.inc\
-dumb-kode54/src/helpers/resamp2.inc\
-dumb-kode54/src/helpers/resamp3.inc\
cdumb.c
-endif
+
+OBJECTS=$(SOURCES:.c=.o)
+
+OUT=dumb.so
+
+all: $(SOURCES) $(OUT)
+
+$(OUT): $(OBJECTS)
+ $(CC) $(LDFLAGS) $(OBJECTS) -o $@
+
+.c.o:
+ $(CC) $(CFLAGS) $< -c -o $@
+
+clean:
+ rm $(OBJECTS) $(OUT)
+