summaryrefslogtreecommitdiff
path: root/doc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile')
-rw-r--r--doc/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/doc/Makefile b/doc/Makefile
index fd508e07..6209b0c8 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -110,7 +110,7 @@ REFMANCOQTEXFILES=\
refman/RefMan-mod.v.tex refman/RefMan-tac.v.tex \
refman/RefMan-cic.v.tex refman/RefMan-lib.v.tex \
refman/RefMan-tacex.v.tex refman/RefMan-syn.v.tex \
- refman/RefMan-oth.v.tex \
+ refman/RefMan-oth.v.tex refman/RefMan-ltac.v.tex \
refman/Cases.v.tex refman/Coercion.v.tex refman/Extraction.v.tex \
refman/Program.v.tex refman/Omega.v.tex refman/Polynom.v.tex \
refman/Setoid.v.tex refman/Helm.tex # refman/Natural.v.tex
@@ -119,7 +119,7 @@ REFMANTEXFILES=\
refman/headers.tex \
refman/Reference-Manual.tex refman/RefMan-pre.tex \
refman/RefMan-int.tex refman/RefMan-pro.tex \
- refman/RefMan-com.tex refman/RefMan-ltac.tex \
+ refman/RefMan-com.tex \
refman/RefMan-uti.tex refman/RefMan-ide.tex \
refman/RefMan-add.tex refman/RefMan-modr.tex \
$(REFMANCOQTEXFILES) \
@@ -161,9 +161,15 @@ refman/html/index.html: refman/Reference-Manual.html $(REFMANPNGFILES) \
mkdir refman/html
cp $(REFMANPNGFILES) refman/html
(cd refman/html; hacha -o toc.html ../Reference-Manual.html)
- cp refman/cover.html refman/html
+ cp refman/cover.html refman/menu.html refman/html
cp refman/index.html refman/html
+refman-quick:
+ (cd refman; \
+ $(PDFLATEX) Reference-Manual.tex; \
+ hevea -fix -exec xxdate.exe ./Reference-Manual.tex)
+
+
######################################################################
# Tutorial
######################################################################