summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 6bdb7e65..c8a416b8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -42,7 +42,11 @@ build-stamp:
else \
$(MAKE) BEST=byte HASCOQIDE=byte check; \
fi
- $(MAKE) glob.dump
+ if [ -e opt-stamp ]; then \
+ $(MAKE) BEST=opt glob.dump; \
+ else \
+ $(MAKE) BEST=byte HASCOQIDE=byte glob.dump; \
+ fi
cp tools/coqdoc/coqdoc.sty doc/stdlib/
$(MAKE) -C doc stdlib/html/index.html
touch build-stamp