summaryrefslogtreecommitdiff
path: root/Makefile.common
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.common')
-rw-r--r--Makefile.common23
1 files changed, 14 insertions, 9 deletions
diff --git a/Makefile.common b/Makefile.common
index 3740b52e..c5969d17 100644
--- a/Makefile.common
+++ b/Makefile.common
@@ -73,16 +73,21 @@ COQBINARIES:= $(COQMKTOP) $(COQC) \
CSDPCERT:=plugins/micromega/csdpcert$(EXE)
+CORESRCDIRS:=\
+ config lib kernel kernel/byterun library \
+ proofs tactics pretyping interp toplevel \
+ parsing
+
+PLUGINS:=\
+ omega romega micromega quote ring \
+ setoid_ring xml extraction fourier \
+ cc funind firstorder field subtac \
+ rtauto nsatz syntax decl_mode
+
SRCDIRS:=\
- config tools tools/coqdoc scripts lib \
- kernel kernel/byterun library proofs tactics \
- pretyping interp toplevel/utils toplevel parsing \
- ide/utils ide \
- $(addprefix plugins/, \
- omega romega micromega quote ring \
- setoid_ring xml extraction fourier \
- cc funind firstorder field subtac \
- rtauto nsatz syntax decl_mode)
+ $(CORESRCDIRS) \
+ tools tools/coqdoc scripts ide/utils ide \
+ $(addprefix plugins/, $(PLUGINS))
# Order is relevent here because kernel and checker contain files
# with the same name