summaryrefslogtreecommitdiff
path: root/INSTALL.doc
diff options
context:
space:
mode:
Diffstat (limited to 'INSTALL.doc')
-rw-r--r--INSTALL.doc41
1 files changed, 31 insertions, 10 deletions
diff --git a/INSTALL.doc b/INSTALL.doc
index 2472d2b2..f8a08528 100644
--- a/INSTALL.doc
+++ b/INSTALL.doc
@@ -22,25 +22,42 @@ To produce all the documents, the following tools are needed:
- dvips
- bibtex
- makeindex
- - fig2dev (transfig)
- - convert (ImageMagick)
- hevea
- - hacha
+ - Python 3
+ - Sphinx 1.6.5 (http://www.sphinx-doc.org/en/stable/)
+ - sphinx_rtd_theme
+ - pexpect
+ - beautifulsoup4
+ - Antlr4 runtime for Python 3
-Under Debian based operating systems (Debian, Ubuntu, ...) a
-working set of packages for compiling the documentation for Coq is:
+Under recent Debian based operating systems (Debian 10 "Buster",
+Ubuntu 18.04, ...) a working set of packages for compiling the
+documentation for Coq is:
- texlive texlive-latex-extra texlive-math-extra texlive-fonts-extra
- texlive-humanities texlive-pictures latex-xcolor hevea transfig
- imagemagick
+ texlive-latex-extra texlive-fonts-recommended hevea python3-sphinx
+ python3-pexpect python3-sphinx-rtd-theme python3-bs4
+ python3-sphinxcontrib.bibtex python3-pip
+Then, install the Python3 Antlr4 package:
+
+ pip3 install antlr4-python3-runtime
+
+Nix users should get the correct development environment to build the
+Sphinx documentation from Coq's `default.nix`. [Note Nix setup doesn't
+include the LaTeX packages needed to build the full documentation.]
+
+If you are in an older/different distribution you can install the
+Python packages required to build the user manual using python3-pip:
+
+ pip3 install sphinx sphinx_rtd_theme beautifulsoup4 antlr4-python3-runtime pexpect sphinxcontrib-bibtex
Compilation
-----------
To produce all documentation about Coq, just run:
+ ./configure (if you hadn't already)
make doc
@@ -55,8 +72,8 @@ Alternatively, you can use some specific targets:
make doc-html
to produce all html documents
- make refman
- to produce all formats of the reference manual
+ make sphinx
+ to produce the HTML version of the reference manual
make tutorial
to produce all formats of the tutorial
@@ -71,6 +88,10 @@ Alternatively, you can use some specific targets:
to produce all formats of the Coq standard library
+Also note the "-with-doc yes" option of ./configure to enable the
+build of the documentation as part of the default make target.
+
+
Installation
------------