summaryrefslogtreecommitdiff
path: root/.gitignore
diff options
context:
space:
mode:
Diffstat (limited to '.gitignore')
-rw-r--r--.gitignore76
1 files changed, 45 insertions, 31 deletions
diff --git a/.gitignore b/.gitignore
index 965adf7a..16d011c3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,9 +3,11 @@
*.d.raw
*.vo
*.cm*
+*.annot
+*.spit
+*.spot
*.o
*.a
-*.annot
*.log
*.aux
*.dvi
@@ -13,31 +15,33 @@
*.bbl
*.idx
*.ilg
-*.lof
*.toc
*.atoc
*.comidx
*.comind
-*.tacidx
-*.tacind
*.erridx
*.errind
-*.ind
+*.haux
*.hcomind
-*.htacind
*.herrind
*.hind
-*.haux
+*.htacind
*.htoc
+*.ind
+*.lof
+*.stamp
+*.tacidx
+*.tacind
*.v.tex
-*.v.ps
*.v.pdf
+*.v.ps
*.v.html
-bin
+revision
+TAGS
+bin/
config/Makefile
config/coq_config.ml
-contrib/dp/dp_zenon.ml
-contrib/micromega/csdpcert
+plugins/dp/dp_zenon.ml
dev/ocamldebug-coq
dev/ocamlweb-doc/lex.ml
dev/ocamlweb-doc/syntax.ml
@@ -45,46 +49,56 @@ dev/ocamlweb-doc/syntax.mli
ide/config_lexer.ml
ide/config_parser.ml
ide/config_parser.mli
+ide/coq_lex.ml
+ide/extract_index.ml
+ide/find_phrase.ml
ide/highlight.ml
-ide/index_urls.txt
ide/undo.mli
ide/utf8_convert.ml
-ide/extract_index.ml
-ide/find_phrase.ml
-kernel/copcodes.ml
kernel/byterun/coq_jumptbl.h
+kernel/byterun/dllcoqrun.so
+kernel/copcodes.ml
scripts/tolink.ml
states/initial.coq
-theories/Numbers/Natural/BigN/NMake.v
+test-suite/lia.cache
+test-suite/trace
+theories/Numbers/Natural/BigN/NMake_gen.v
tools/coqdep_lexer.ml
+tools/coqdoc/cpretty.ml
tools/coqwc.ml
tools/gallina_lexer.ml
-tools/coqdoc/pretty.ml
-tools/coqdoc/index.ml
-toplevel/mltop.byteml
toplevel/mltop.optml
-doc/RecTutorial/RecTutorial.html
-doc/common/version.tex
-doc/faq/html
-doc/RecTutorial/RecTutorial.pdf
-doc/RecTutorial/RecTutorial.ps
+plugins/micromega/csdpcert
+toplevel/mltop.byteml
+coqdoc.sty
+ide/index_urls.txt
+doc/faq/html/
+doc/refman/Reference-Manual.pdf
+doc/refman/Reference-Manual.ps
+doc/refman/cover.html
+doc/refman/styles.hva
doc/refman/Reference-Manual.html
+doc/common/version.tex
doc/refman/Reference-Manual.sh
-doc/refman/Reference-Manual.ps
-doc/refman/Reference-Manual.pdf
doc/refman/coqide-queries.eps
doc/refman/coqide.eps
-doc/refman/cover.html
doc/refman/euclid.ml
doc/refman/euclid.mli
doc/refman/heapsort.ml
doc/refman/heapsort.mli
-doc/refman/html
-doc/refman/styles.hva
-doc/stdlib/Library.coqdoc.tex
+doc/refman/html/
doc/stdlib/Library.out
doc/stdlib/Library.pdf
doc/stdlib/Library.ps
+doc/stdlib/Library.coqdoc.tex
doc/stdlib/html/
+doc/stdlib/index-body.html
doc/stdlib/index-list.html
-kernel/byterun/dllcoqrun.so
+doc/RecTutorial/RecTutorial.html
+doc/RecTutorial/RecTutorial.pdf
+doc/RecTutorial/RecTutorial.ps
+dev/doc/naming-conventions.pdf
+_build
+plugins/*/*_mod.ml
+myocamlbuild_config.ml
+.DS_Store