summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@debian.org>2018-12-29 16:41:25 -0500
committerGravatar Benjamin Barenblat <bbaren@debian.org>2019-01-03 18:24:39 -0500
commite23d443a3a64b30a77e8ea92f347f933a865bb99 (patch)
treef7a93310dbf79eece9b4e567ecebeb2714862d07 /debian/rules
parent2ab1f145256e0b96045963053e20b86e560a2fc5 (diff)
Disable tests which require `-coqlib` to be set
A number of tests (mostly for coq_makefile) assume that Coq is installed when the test runs. This isn't true in an sbuild environment, though, so disable those tests.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index c12c540d..8c97cf17 100755
--- a/debian/rules
+++ b/debian/rules
@@ -79,7 +79,8 @@ endif
.PHONY: override_dh_auto_test
override_dh_auto_test:
- $(MAKE) test-suite COMPLEXITY=
+ CAML_LD_LIBRARY_PATH=$PWD/kernel/byterun COQLIB=$PWD \
+ $(MAKE) test-suite COMPLEXITY=
.PHONY: override_dh_auto_install
override_dh_auto_install: