summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Enrico Tassi <gareuselesinge@debian.org>2015-07-20 09:52:10 +0200
committerGravatar Enrico Tassi <gareuselesinge@debian.org>2015-07-20 09:52:10 +0200
commitd57f8a932cc2ca71b9583df4b8e9fb111f80b180 (patch)
tree206048082c959247dba58844982eedb5d465ad46 /debian/rules
parent1b014807aa88271b107b5cbb9e2d8bb471e9208f (diff)
disable native compiler on non-mainstream arches
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 9 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index d75b48e0..de43511e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -25,12 +25,20 @@ PACKAGES := $(shell dh_listpackages)
COQ_VERSION := 8.5beta2
COQ_ABI := $(COQ_VERSION)+$(OCAML_ABI)
+ARCH := $(shell dpkg-architecture -q DEB_TARGET_ARCH)
+ifeq ($(ARCH),$(filter $(ARCH),amd64 i386))
+NATIVE_COMPUTE :=
+else
+NATIVE_COMPUTE := -no-native-compiler
+endif
+
CONFIGUREOPTS := -arch Linux -prefix /usr -mandir /usr/share/man \
-configdir /etc/xdg/coq \
-emacslib /usr/share/emacs/site-lisp/coq \
-browser "/usr/bin/x-www-browser %s &" \
-with-doc no \
- -debug
+ -debug \
+ $(NATIVE_COMPUTE)
export OCAMLINIT_SED += \
-e 's%@CoqVersion@%$(COQ_VERSION)%' \