summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2010-06-03 11:59:43 +0200
committerGravatar Stephane Glondu <steph@glondu.net>2010-07-01 17:33:20 +0200
commit9f8c291384c4e81939a92fccc4674b4611fa856f (patch)
tree1ff29ca15a877b94b2a59e7b861299e15428e264 /debian/rules
parent7c9acaaecd06f9350b94b04b74106cd0a5f5de55 (diff)
Use debhelper more thoroughly
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 1 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 997f99fe..12e6d874 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,7 +21,7 @@ HTMLDOC := doc/stdlib/html/index.html
COQPREF := $(CURDIR)/debian/tmp
ADDPREF := COQINSTALLPREFIX=$(COQPREF)
-PACKAGES := $(shell awk '/Package:/{print $$2}' debian/control)
+PACKAGES := $(shell dh_listpackages)
COQ_VERSION := $(shell head -n1 debian/changelog | awk -F'[+() ]' '{print $$3}')
COQ_ABI := $(COQ_VERSION)+$(OCAML_ABI)
@@ -71,11 +71,7 @@ install-stamp: build-stamp
find debian/tmp -name '*.vo' -printf '%P\n' \
>> debian/coq-theories.install
dh_install --list-missing
- cp debian/coq.xpm debian/coq/usr/share/pixmaps
cp debian/coq.xpm debian/coqide/usr/share/pixmaps/coqide.xpm
- cp debian/coqide.desktop debian/coqide/usr/share/applications
- cp -r doc/stdlib/html debian/coq-theories/usr/share/doc/coq-theories/
- cp debian/coqvars.mk debian/coq/usr/share/coq/
$(DH) install --after dh_install
for u in $(PACKAGES); do \
echo 'F:OCamlABI=$(OCAML_ABI)' >> debian/$$u.substvars; \