summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Enrico Tassi <gareuselesinge@debian.org>2015-07-14 12:40:07 +0200
committerGravatar Enrico Tassi <gareuselesinge@debian.org>2015-07-14 16:46:37 +0200
commit9d22a41a7047e6462c28a11203bf30b7657a4b53 (patch)
treee027da54c624111d808081e2d3ff1acf51d4975b /debian/rules
parentf219abfed720305c13875c3c63f9240cf63f78bc (diff)
Packaging 8.5beta1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules33
1 files changed, 25 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 6343da50..cbc46469 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,14 +22,15 @@ ADDPREF := COQINSTALLPREFIX=$(COQPREF) OLDROOT=
PACKAGES := $(shell dh_listpackages)
-COQ_VERSION := 8.4pl4
+COQ_VERSION := 8.5beta1
COQ_ABI := $(COQ_VERSION)+$(OCAML_ABI)
-CONFIGUREOPTS := --arch Linux --prefix /usr --mandir /usr/share/man \
- --configdir /etc/xdg/coq \
- --emacslib /usr/share/emacs/site-lisp/coq \
- --browser "/usr/bin/x-www-browser %s &" \
- --with-doc no --coqrunbyteflags "-dllib -lcoqrun"
+CONFIGUREOPTS := -arch Linux -prefix /usr -mandir /usr/share/man \
+ -configdir /etc/xdg/coq \
+ -emacslib /usr/share/emacs/site-lisp/coq \
+ -browser "/usr/bin/x-www-browser %s &" \
+ -with-doc no \
+ -debug
export OCAMLINIT_SED += \
-e 's%@CoqVersion@%$(COQ_VERSION)%' \
@@ -58,6 +59,9 @@ ifeq ($(BUILDCACHE),)
$(MAKE) world STRIP=true
$(MAKE) DOC_TARGETS=$(HTMLDOC) $(HTMLDOC)
+ # uncomment to create the cache
+ #mkdir ../coq.cache
+ #rsync -a --exclude=debian --exclude=.git . ../coq.cache/
else
rsync -a --exclude=debian --exclude=.git $(BUILDCACHE)/ .
endif
@@ -70,22 +74,35 @@ endif
.PHONY: override_dh_auto_test
override_dh_auto_test:
- $(MAKE) check COMPLEXITY= BESTCHICKEN=/bin/true
+ # disabled since beta1 does not pass all tests
+ #$(MAKE) test-suite COMPLEXITY=
.PHONY: override_dh_auto_install
override_dh_auto_install:
$(MAKE) $(ADDPREF) install
find debian/tmp -regextype posix-awk \
- -regex '.*\.(cm[xi]|cmxa|[ao])$$' \
+ -regex '.*\.(cmi|cmx|cmxa|[ao])$$' \
+ | grep -v toploop/ | grep -v coq-native \
>> debian/libcoq-ocaml-dev.install
find debian/tmp -name '*.vo' -printf '%P\n' \
>> debian/coq-theories.install
+ find debian/tmp -name '*.v' -printf '%P\n' \
+ >> debian/coq-theories.install
+ find debian/tmp -name '*.glob' -printf '%P\n' \
+ >> debian/coq-theories.install
+ find debian/tmp -name '.coq-native' -printf '%P\n' \
+ >> debian/coq-theories.install
.PHONY: override_dh_install
override_dh_install:
dh_install --fail-missing
cp debian/coq.xpm debian/coqide/usr/share/pixmaps/coqide.xpm
+.PHONY: override_dh_ocaml
+override_dh_ocaml:
+ dh_ocaml --nodefined-map coqide:Xmlprotocol,Ide_slave
+ for f in debian/*substvars; do echo $$f; cat $$f; done
+
.PHONY: override_dh_gencontrol
override_dh_gencontrol:
for u in $(PACKAGES); do \