summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2009-12-03 11:21:58 +0100
committerGravatar Stephane Glondu <steph@glondu.net>2009-12-03 11:40:45 +0100
commit668a6055913e047843f505f09c89a8a7badd4dff (patch)
treee77b8f494a0dd3b1ae1240d3710ed60fa4689199 /debian/rules
parentf8fd65f3e3e349d00c4d2b38f625564af7a093c6 (diff)
Switch to dh-ocaml 0.9
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 6 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 71b8d68c..4f907015 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,7 +14,7 @@ export CAML_LD_LIBRARY_PATH = $(shell pwd)/kernel/byterun
# Show full commands when building Coq
export VERBOSE=1
-include /usr/share/ocaml/ocamlinit.mk
+include /usr/share/ocaml/ocamlvars.mk
HTMLDOC := doc/stdlib/html/index.html
@@ -31,14 +31,14 @@ CONFIGUREOPTS := --arch Linux --prefix /usr --mandir /usr/share/man \
--browser "/usr/bin/x-www-browser %s &" \
--with-doc no --coqrunbyteflags "-dllib -lcoqrun"
-OCAMLINIT_SED += \
+export OCAMLINIT_SED += \
-e 's%@CoqVersion@%$(COQ_VERSION)%' \
-e 's%@CoqABI@%$(COQ_ABI)%'
-DH := dh --with quilt
+DH := dh --with quilt,ocaml
configure: configure-stamp
-configure-stamp: ocamlinit-stamp
+configure-stamp:
$(DH) build --before dh_auto_configure
./configure $(CONFIGUREOPTS)
touch $@
@@ -83,7 +83,7 @@ install-stamp: build-stamp
done
touch $@
-clean: ocamlinit-clean
+clean:
$(DH) $@
binary-indep: install-stamp
@@ -93,4 +93,4 @@ binary-arch: install-stamp
$(DH) $@
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure ocamlinit
+.PHONY: build clean binary-indep binary-arch binary install configure