summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2008-07-25 15:39:04 +0200
committerGravatar Samuel Mimram <smimram@debian.org>2008-07-25 15:39:04 +0200
commit56f3368635e32e891701859d8345fb98b7da6fd7 (patch)
tree4ceb6fc1dd71d7ad626cedeb4ce1cb247dd2ab3e /debian/patches
parentd5e0af8d900a4556ea1f043a9c350ee1dc6be0cf (diff)
Updated and removed old patches.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/00list4
-rwxr-xr-xdebian/patches/browser.dpatch18
-rwxr-xr-xdebian/patches/check.dpatch6
-rwxr-xr-xdebian/patches/cmxa-install.dpatch23
-rwxr-xr-xdebian/patches/configure.dpatch19
-rwxr-xr-xdebian/patches/coqdoc_stdlib.dpatch19
-rwxr-xr-xdebian/patches/makefile.dpatch20
-rwxr-xr-x[-rw-r--r--]debian/patches/no-complexity-test.dpatch12
8 files changed, 18 insertions, 103 deletions
diff --git a/debian/patches/00list b/debian/patches/00list
index bf00e3ce..96c8fc3a 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,7 +1,3 @@
-coqdoc_stdlib
browser
-makefile
no-complexity-test
-configure
-cmxa-install
check
diff --git a/debian/patches/browser.dpatch b/debian/patches/browser.dpatch
index 9a15372c..15647950 100755
--- a/debian/patches/browser.dpatch
+++ b/debian/patches/browser.dpatch
@@ -5,15 +5,15 @@
## DP: Use the default Debian browser for help.
@DPATCH@
-diff -urNad coq-8.1.pl2+dfsg~/lib/options.ml coq-8.1.pl2+dfsg/lib/options.ml
---- coq-8.1.pl2+dfsg~/lib/options.ml 2007-10-15 11:00:52.000000000 +0000
-+++ coq-8.1.pl2+dfsg/lib/options.ml 2007-10-15 11:01:51.000000000 +0000
-@@ -118,7 +118,4 @@
- "\" must contain exactly one placeholder \"%s\".")
- else pre,post
+diff -urNad coq~/lib/flags.ml coq/lib/flags.ml
+--- coq~/lib/flags.ml 2008-07-25 15:13:00.000000000 +0200
++++ coq/lib/flags.ml 2008-07-25 15:30:47.000000000 +0200
+@@ -126,7 +126,4 @@
+ let coq_netscape_remote_var = "COQREMOTEBROWSER" in
+ Sys.getenv coq_netscape_remote_var
with
- Not_found ->
- if Sys.os_type = "Win32"
-- then "C:\\PROGRA~1\\INTERN~1\\IEXPLORE ", ""
-- else "firefox -remote \"OpenURL(", ")\""
-+ Not_found -> "/usr/bin/x-www-browser ", ""
+- then "C:\\PROGRA~1\\INTERN~1\\IEXPLORE %s"
+- else "firefox -remote \"OpenURL(%s,new-tab)\" || firefox %s &"
++ Not_found -> "/usr/bin/x-www-browser %s &"
diff --git a/debian/patches/check.dpatch b/debian/patches/check.dpatch
index 620b18a7..d0cb3907 100755
--- a/debian/patches/check.dpatch
+++ b/debian/patches/check.dpatch
@@ -5,9 +5,9 @@
## DP: Suppress warnings from tests outputs.
@DPATCH@
-diff -urNad coq-8.1.pl2+dfsg~/test-suite/check coq-8.1.pl2+dfsg/test-suite/check
---- coq-8.1.pl2+dfsg~/test-suite/check 2007-11-29 14:02:40.000000000 +0000
-+++ coq-8.1.pl2+dfsg/test-suite/check 2007-11-29 14:03:39.000000000 +0000
+diff -urNad coq~/test-suite/check coq/test-suite/check
+--- coq~/test-suite/check 2008-07-25 15:36:31.000000000 +0200
++++ coq/test-suite/check 2008-07-25 15:36:31.000000000 +0200
@@ -52,7 +52,7 @@
nbtests=`expr $nbtests + 1`
printf " "$f"..."
diff --git a/debian/patches/cmxa-install.dpatch b/debian/patches/cmxa-install.dpatch
deleted file mode 100755
index 7e8d2ffb..00000000
--- a/debian/patches/cmxa-install.dpatch
+++ /dev/null
@@ -1,23 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## cmxa-install.dpatch by Samuel Mimram <smimram@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: .cmxa are not generated on non-native archs, so don't install them.
-
-@DPATCH@
-diff -urNad coq-8.1+dfsg~/Makefile coq-8.1+dfsg/Makefile
---- coq-8.1+dfsg~/Makefile 2007-02-18 13:25:29.000000000 +0100
-+++ coq-8.1+dfsg/Makefile 2007-02-18 13:27:28.000000000 +0100
-@@ -1272,7 +1272,11 @@
- parsing/parsing.cma tactics/tactics.cma toplevel/toplevel.cma \
- parsing/highparsing.cma tactics/hightactics.cma contrib/contrib.cma
-
--OBJECTCMXA=$(OBJECTCMA:.cma=.cmxa)
-+ifeq ($(BEST),opt)
-+ OBJECTCMXA=$(OBJECTCMA:.cma=.cmxa)
-+else
-+ OBJECTCMXA=
-+endif
-
- install-library:
- $(MKDIR) $(FULLCOQLIB)
diff --git a/debian/patches/configure.dpatch b/debian/patches/configure.dpatch
deleted file mode 100755
index db3ef2a5..00000000
--- a/debian/patches/configure.dpatch
+++ /dev/null
@@ -1,19 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## configure.dpatch by Pierre Letouzey <pierre.letouzey@pps.jussieu.fr>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Correctly detect whether ocamlopt is present or not.
-
-@DPATCH@
-diff -urNad coq-8.1+dfsg~/configure coq-8.1+dfsg/configure
---- coq-8.1+dfsg~/configure 2007-02-10 08:32:28.000000000 +0000
-+++ coq-8.1+dfsg/configure 2007-02-15 12:58:56.000000000 +0000
-@@ -340,7 +340,7 @@
- # do we have a native compiler: test of ocamlopt and its version
-
- if [ "$best_compiler" = "opt" ] ; then
-- if test -e `which "$nativecamlc"` ; then
-+ if test -e "`which $nativecamlc`" ; then
- CAMLOPTVERSION=`"$nativecamlc" -v | sed -n -e 's|.*version* *\(.*\)$|\1|p' `
- if [ "$CAMLOPTVERSION" != "$CAMLVERSION" ] ; then
- echo "native and bytecode compilers do not have the same version!"; fi
diff --git a/debian/patches/coqdoc_stdlib.dpatch b/debian/patches/coqdoc_stdlib.dpatch
deleted file mode 100755
index f59f52e0..00000000
--- a/debian/patches/coqdoc_stdlib.dpatch
+++ /dev/null
@@ -1,19 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## coqdoc_stdlib.dpatch by Samuel Mimram <smimram@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Add an option to coqdoc to be able to use a custom stdlib path in order
-## DP: to be able to build the documentation before coqdoc is installed.
-
-@DPATCH@
-diff -urNad coq-8.1.pl2+dfsg~/doc/Makefile coq-8.1.pl2+dfsg/doc/Makefile
---- coq-8.1.pl2+dfsg~/doc/Makefile 2007-10-15 11:45:13.000000000 +0000
-+++ coq-8.1.pl2+dfsg/doc/Makefile 2007-10-15 11:45:40.000000000 +0000
-@@ -222,6 +222,7 @@
- mkdir stdlib/html
- (cd stdlib/html;\
- $(COQDOC) -q --multi-index --html --glob-from $(GLOBDUMP)\
-+ --coqlib_path $(COQSRC) \
- -R $(COQSRC)/theories Coq $(COQSRC)/theories/*/*.v)
- mv stdlib/html/index.html stdlib/index-body.html
-
diff --git a/debian/patches/makefile.dpatch b/debian/patches/makefile.dpatch
deleted file mode 100755
index d16030ca..00000000
--- a/debian/patches/makefile.dpatch
+++ /dev/null
@@ -1,20 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## makefile.dpatch by Samuel Mimram <smimram@debian.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Do not use ocamlopt to test grammar.cma, we don't want to use ocamlopt
-## DP: when compiling on non-native archs.
-
-@DPATCH@
-diff -urNad coq-8.1.pl2+dfsg~/Makefile coq-8.1.pl2+dfsg/Makefile
---- coq-8.1.pl2+dfsg~/Makefile 2007-10-15 11:02:54.000000000 +0000
-+++ coq-8.1.pl2+dfsg/Makefile 2007-10-15 11:03:55.000000000 +0000
-@@ -1479,7 +1479,7 @@
- parsing/grammar.cma: $(GRAMMARCMO)
- $(SHOW)'Testing $@'
- @touch test.ml4
-- $(HIDE)$(OCAMLOPT) $(OPTFLAGS) -pp "$(CAMLP4O) $(CAMLP4EXTENSIONS) $(GRAMMARCMO) -impl" -impl test.ml4 -o test-grammar
-+ $(HIDE)$(OCAMLC) $(BYTEFLAGS) -pp "$(CAMLP4O) $(CAMLP4EXTENSIONS) $(GRAMMARCMO) -impl" -impl test.ml4 -o test-grammar
- @rm -f test-grammar test.*
- $(SHOW)'OCAMLC -a $@'
- $(HIDE)$(OCAMLC) $(BYTEFLAGS) $(GRAMMARCMO) -linkall -a -o $@
diff --git a/debian/patches/no-complexity-test.dpatch b/debian/patches/no-complexity-test.dpatch
index bf89f1f7..5f9bff67 100644..100755
--- a/debian/patches/no-complexity-test.dpatch
+++ b/debian/patches/no-complexity-test.dpatch
@@ -5,13 +5,13 @@
## DP: Don't run complexity tests, they are far too fragile.
@DPATCH@
-diff -urNad coq-8.1gamma~/test-suite/check coq-8.1gamma/test-suite/check
---- coq-8.1gamma~/test-suite/check 2006-11-03 14:07:27.000000000 +0100
-+++ coq-8.1gamma/test-suite/check 2006-11-23 15:19:49.000000000 +0100
-@@ -145,8 +145,8 @@
- test_parser parser
- echo "Interactive tests"
+diff -urNad coq~/test-suite/check coq/test-suite/check
+--- coq~/test-suite/check 2008-07-25 15:13:00.000000000 +0200
++++ coq/test-suite/check 2008-07-25 15:33:55.000000000 +0200
+@@ -250,8 +250,8 @@
test_interactive interactive
+ echo "Micromega tests"
+ test_success micromega
-echo "Complexity tests"
-test_complexity complexity
+echo "Skipping complexity tests"