summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2007-02-18 12:29:49 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2007-02-18 12:29:49 +0000
commit3e049918b485edc6561dee8dd656207f2fc0a19a (patch)
tree2ebc956cc37ffc685673151ac8f1728279554ac6 /debian/patches
parent4d9badb29a176d1feb8ae8da287b3e2f2d1afe36 (diff)
Install cmxa only on native archs.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/cmxa-install.dpatch23
2 files changed, 24 insertions, 0 deletions
diff --git a/debian/patches/00list b/debian/patches/00list
index 7f4a29f0..bbb91a76 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -3,3 +3,4 @@ browser
makefile
no-complexity-test
configure
+cmxa-install
diff --git a/debian/patches/cmxa-install.dpatch b/debian/patches/cmxa-install.dpatch
new file mode 100755
index 00000000..7e8d2ffb
--- /dev/null
+++ b/debian/patches/cmxa-install.dpatch
@@ -0,0 +1,23 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## cmxa-install.dpatch by Samuel Mimram <smimram@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: .cmxa are not generated on non-native archs, so don't install them.
+
+@DPATCH@
+diff -urNad coq-8.1+dfsg~/Makefile coq-8.1+dfsg/Makefile
+--- coq-8.1+dfsg~/Makefile 2007-02-18 13:25:29.000000000 +0100
++++ coq-8.1+dfsg/Makefile 2007-02-18 13:27:28.000000000 +0100
+@@ -1272,7 +1272,11 @@
+ parsing/parsing.cma tactics/tactics.cma toplevel/toplevel.cma \
+ parsing/highparsing.cma tactics/hightactics.cma contrib/contrib.cma
+
+-OBJECTCMXA=$(OBJECTCMA:.cma=.cmxa)
++ifeq ($(BEST),opt)
++ OBJECTCMXA=$(OBJECTCMA:.cma=.cmxa)
++else
++ OBJECTCMXA=
++endif
+
+ install-library:
+ $(MKDIR) $(FULLCOQLIB)