summaryrefslogtreecommitdiff
path: root/debian/patches/coqdoc_stdlib.dpatch
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2007-04-09 15:19:11 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2007-04-09 15:19:11 +0000
commitcb73a339553ac8a5449b3bf850207ed7500ff147 (patch)
tree7d40fc574e70c01211d07d84e9276cc7d814dd5d /debian/patches/coqdoc_stdlib.dpatch
parent9636b0c333690f13552f68e38a76fc070cf14762 (diff)
Uploading to unstable.debian/8.1+dfsg-3
Diffstat (limited to 'debian/patches/coqdoc_stdlib.dpatch')
-rwxr-xr-xdebian/patches/coqdoc_stdlib.dpatch19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/patches/coqdoc_stdlib.dpatch b/debian/patches/coqdoc_stdlib.dpatch
new file mode 100755
index 00000000..fb618f56
--- /dev/null
+++ b/debian/patches/coqdoc_stdlib.dpatch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## coqdoc_stdlib.dpatch by Samuel Mimram <smimram@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Add an option to coqdoc to be able to use a custom stdlib path in order
+## DP: to be able to build the documentation before coqdoc is installed.
+
+@DPATCH@
+diff -urNad coq-8.0pl3+8.1beta~/doc/Makefile coq-8.0pl3+8.1beta/doc/Makefile
+--- coq-8.0pl3+8.1beta~/doc/Makefile 2006-06-16 13:02:33.000000000 +0000
++++ coq-8.0pl3+8.1beta/doc/Makefile 2006-06-16 13:19:11.000000000 +0000
+@@ -216,6 +216,7 @@
+ mkdir stdlib/html
+ (cd stdlib/html;\
+ $(COQDOC) -q --multi-index --html --glob-from $(GLOBDUMP)\
++ --coqlib_path $(COQTOP) \
+ -R $(COQTOP)/theories Coq $(COQTOP)/theories/*/*.v)
+ mv stdlib/html/index.html stdlib/index-body.html
+