summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2006-07-13 14:28:31 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2006-07-13 14:28:31 +0000
commitde0085539583f59dc7c4bf4e272e18711d565466 (patch)
tree347e1d95a2df56f79a01b303e485563588179e91 /configure
parente978da8c41d8a3c19a29036d9c569fbe2a4616b0 (diff)
Imported Upstream version 8.0pl3+8.1beta.2upstream/8.0pl3+8.1beta.2
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure393
1 files changed, 215 insertions, 178 deletions
diff --git a/configure b/configure
index f2bb36b9..71217486 100755
--- a/configure
+++ b/configure
@@ -30,6 +30,8 @@ coq_profile_flag=
best_compiler=opt
local=false
+src_spec=no
+prefix_spec=no
bindir_spec=no
libdir_spec=no
mandir_spec=no
@@ -44,7 +46,7 @@ arch_spec=no
coqide_spec=no
with_geoproof=true
-COQTOP=`pwd`
+# COQTOP=`pwd`
# Parse command-line arguments
@@ -52,49 +54,32 @@ COQTOP=`pwd`
while : ; do
case "$1" in
"") break;;
- -prefix|--prefix) bindir_spec=yes
- bindir=$2/bin
- libdir_spec=yes
- libdir=$2/lib/coq
- mandir_spec=yes
- mandir=$2/man
- coqdocdir_spec=yes
- coqdocdir=$2/share/texmf/tex/latex/misc
+ -prefix|--prefix) prefix_spec=yes
+ prefix="$2"
shift;;
-local|--local) local=true
- bindir_spec=yes
- bindir=$COQTOP/bin
- libdir_spec=yes
- libdir=$COQTOP
- mandir_spec=yes
- mandir=$COQTOP/man
- emacslib_spec=yes
- emacslib=$COQTOP/tools/emacs
- coqdocdir_spec=yes
- coqdocdir=$COQTOP/tools/coqdoc
- fsets_opt=yes
- fsets=all
reals_opt=yes
reals=all;;
- -src|--src) COQTOP=$2
+ -src|--src) src_spec=yes
+ COQTOP="$2"
shift;;
-bindir|--bindir) bindir_spec=yes
- bindir=$2
+ bindir="$2"
shift;;
-libdir|--libdir) libdir_spec=yes
- libdir=$2
+ libdir="$2"
shift;;
-mandir|--mandir) mandir_spec=yes
- mandir=$2
+ mandir="$2"
shift;;
-emacslib|--emacslib) emacslib_spec=yes
- emacslib=$2
+ emacslib="$2"
shift;;
-emacs |--emacs) emacs_spec=yes
- emacs=$2
+ emacs="$2"
shift;;
-coqdocdir|--coqdocdir) coqdocdir_spec=yes
- coqdocdir=$2
+ coqdocdir="$2"
shift;;
-arch|--arch) arch_spec=yes
arch=$2
@@ -125,6 +110,11 @@ while : ; do
shift
done
+if [ $prefix_spec = yes -a $local = true ] ; then
+ echo "Options -prefix and -local are incompatible"
+ echo "Configure script failed!"
+ exit 1
+fi
# compile date
DATEPGM=`which date`
@@ -160,137 +150,28 @@ case $arch_spec in
yes) ARCH=$arch
esac
-# bindir, libdir, mandir, etc.
-
-case $ARCH in
- win32)
- bindir_def=C:\\coq\\bin
- libdir_def=C:\\coq\\lib
- mandir_def=C:\\coq\\man
- emacslib_def=C:\\coq\\emacs;;
- *)
- bindir_def=/usr/local/bin
- libdir_def=/usr/local/lib/coq
- mandir_def=/usr/local/man
- emacslib_def=/usr/share/emacs/site-lisp
- coqdocdir_def=/usr/share/texmf/tex/latex/misc;;
-esac
-
-emacs_def=emacs
-
-case $bindir_spec in
- no) echo "Where should I install the Coq binaries [$bindir_def] ?"
- read BINDIR
-
- case $BINDIR in
- "") BINDIR=$bindir_def;;
- *) true;;
- esac;;
- yes) BINDIR=$bindir;;
-esac
-
-case $libdir_spec in
- no) echo "Where should I install the Coq library [$libdir_def] ?"
- read LIBDIR
-
- case $LIBDIR in
- "") LIBDIR=$libdir_def;;
- *) true;;
- esac;;
- yes) LIBDIR=$libdir;;
-esac
-
-case $mandir_spec in
- no) echo "Where should I install the Coq man pages [$mandir_def] ?"
- read MANDIR
-
- case $MANDIR in
- "") MANDIR=$mandir_def;;
- *) true;;
- esac;;
- yes) MANDIR=$mandir;;
-esac
-
-case $emacslib_spec in
- no) echo "Where should I install the Coq Emacs mode [$emacslib_def] ?"
- read EMACSLIB
-
- case $EMACSLIB in
- "") EMACSLIB=$emacslib_def;;
- *) true;;
- esac;;
- yes) EMACSLIB=$emacslib;;
-esac
-
-case $coqdocdir_spec in
- no) echo "Where should I install Coqdoc TeX/LaTeX files [$coqdocdir_def] ?"
- read COQDOCDIR
-
- case $COQDOCDIR in
- "") COQDOCDIR=$coqdocdir_def;;
- *) true;;
- esac;;
- yes) COQDOCDIR=$coqdocdir;;
-esac
-
-case $fsets_opt in
- no) echo "Should I compile the complete theory of finite sets [Y/N, default is Y] ?"
- read fsets_ans
-
- case $fsets_ans in
- "N"|"n"|"No"|"NO"|"no")
- fsets=basic;;
- *) fsets=all;;
- esac;;
- yes) true;;
-esac
-
-case $reals_opt in
- no) echo "Should I compile the complete theory of real analysis [Y/N, default is Y] ?"
- read reals_ans
-
- case $reals_ans in
- "N"|"n"|"No"|"NO"|"no")
- reals=basic;;
- *) reals=all;;
- esac;;
- yes) true;;
-esac
-
-# case $emacs_spec in
-# no) echo "Which Emacs command should I use to compile coq.el [$emacs_def] ?"
-# read EMACS
-
-# case $EMACS in
-# "") EMACS=$emacs_def;;
-# *) true;;
-# esac;;
-# yes) EMACS=$emacs;;
-# esac
-
-# OS dependent libraries
+# executable extension
case $ARCH in
- sun4*) OS=`uname -r`
- case $OS in
- 5*) OS="Sun Solaris $OS"
- OSDEPLIBS="-cclib -lunix -cclib -lnsl -cclib -lsocket";;
- *) OS="Sun OS $OS"
- OSDEPLIBS="-cclib -lunix"
- esac;;
- alpha) OSDEPLIBS="-cclib -lunix";;
- win32) OS="Win32"
- OSDEPLIBS="-cclib -lunix";;
- *) OSDEPLIBS="-cclib -lunix"
+ win32) EXE=".exe";;
+ *) EXE=""
esac
-# executable extension
+# strip command
case $ARCH in
- win32) EXE=".exe";;
- *) EXE=""
+ win32)
+ # true -> strip : it exists under cygwin !
+ STRIPCOMMAND="strip";;
+ *)
+ if [ "$coq_profile_flag" = "-p" ] ; then
+ STRIPCOMMAND="true"
+ else
+ STRIPCOMMAND="strip"
+ fi
esac
+#########################################
# Objective Caml programs
CAMLC=`which $bytecamlc`
@@ -372,6 +253,22 @@ CAMLP4BIN=${CAMLBIN}
# CAMLP4LIB=${CAMLLIB}/camlp4
#esac
+# OS dependent libraries
+
+case $ARCH in
+ sun4*) OS=`uname -r`
+ case $OS in
+ 5*) OS="Sun Solaris $OS"
+ OSDEPLIBS="-cclib -lunix -cclib -lnsl -cclib -lsocket";;
+ *) OS="Sun OS $OS"
+ OSDEPLIBS="-cclib -lunix"
+ esac;;
+ alpha) OSDEPLIBS="-cclib -lunix";;
+ win32) OS="Win32"
+ OSDEPLIBS="-cclib -lunix";;
+ *) OSDEPLIBS="-cclib -lunix"
+esac
+
# lablgtk2 and CoqIDE
if [ "$coqide_spec" = "no" ] ; then
@@ -423,6 +320,132 @@ esac
# "") MKTEXLSR=true;;
#esac
+###########################################
+# bindir, libdir, mandir, etc.
+
+canonical_pwd () {
+ocaml 2>&1 1>/dev/null <<EOF
+ prerr_endline(Sys.getcwd());;
+EOF
+}
+
+case $src_spec in
+ no) COQTOP=`canonical_pwd`
+esac
+
+case $ARCH in
+ win32)
+ bindir_def='C:\coq\bin'
+ libdir_def='C:\coq\lib'
+ mandir_def='C:\coq\man'
+ emacslib_def='C:\coq\emacs'
+ coqdocdir_def='C:\coq\latex';;
+ *)
+ bindir_def=/usr/local/bin
+ libdir_def=/usr/local/lib/coq
+ mandir_def=/usr/local/man
+ emacslib_def=/usr/share/emacs/site-lisp
+ coqdocdir_def=/usr/share/texmf/tex/latex/misc;;
+esac
+
+emacs_def=emacs
+
+case $bindir_spec/$prefix_spec/$local in
+ yes/*/*) BINDIR=$bindir ;;
+ */yes/*) BINDIR=$prefix/bin ;;
+ */*/true) BINDIR=$COQTOP/bin ;;
+ *) echo "Where should I install the Coq binaries [$bindir_def] ?"
+ read BINDIR
+ case $BINDIR in
+ "") BINDIR=$bindir_def;;
+ *) true;;
+ esac;;
+esac
+
+case $libdir_spec/$prefix_spec/$local in
+ yes/*/*) LIBDIR=$libdir;;
+ */yes/*)
+ case $ARCH in
+ win32) LIBDIR=$prefix ;;
+ *) LIBDIR=$prefix/lib/coq ;;
+ esac ;;
+ */*/true) LIBDIR=$COQTOP ;;
+ *) echo "Where should I install the Coq library [$libdir_def] ?"
+ read LIBDIR
+ case $LIBDIR in
+ "") LIBDIR=$libdir_def;;
+ *) true;;
+ esac;;
+esac
+
+case $mandir_spec/$prefix_spec/$local in
+ yes/*/*) MANDIR=$mandir;;
+ */yes/*) MANDIR=$prefix/man ;;
+ */*/true) MANDIR=$COQTOP/man ;;
+ *) echo "Where should I install the Coq man pages [$mandir_def] ?"
+ read MANDIR
+ case $MANDIR in
+ "") MANDIR=$mandir_def;;
+ *) true;;
+ esac;;
+esac
+
+case $emacslib_spec/$prefix_spec/$local in
+ yes/*/*) EMACSLIB=$emacslib;;
+ */yes/*)
+ case $ARCH in
+ win32) EMACSLIB=$prefix/emacs ;;
+ *) EMACSLIB=$prefix/share/emacs/site-lisp ;;
+ esac ;;
+ */*/true) EMACSLIB=$COQTOP/tools/emacs ;;
+ *) echo "Where should I install the Coq Emacs mode [$emacslib_def] ?"
+ read EMACSLIB
+ case $EMACSLIB in
+ "") EMACSLIB=$emacslib_def;;
+ *) true;;
+ esac;;
+esac
+
+case $coqdocdir_spec/$prefix_spec/$local in
+ yes/*/*) COQDOCDIR=$coqdocdir;;
+ */yes/*)
+ case $ARCH in
+ win32) COQDOCDIR=$prefix/latex ;;
+ *) COQDOCDIR=$prefix/share/emacs/site-lisp ;;
+ esac ;;
+ */*/true) COQDOCDIR=$COQTOP/tools/coqdoc ;;
+ *) echo "Where should I install Coqdoc TeX/LaTeX files [$coqdocdir_def] ?"
+ read COQDOCDIR
+ case $COQDOCDIR in
+ "") COQDOCDIR=$coqdocdir_def;;
+ *) true;;
+ esac;;
+esac
+
+case $reals_opt in
+ no) echo "Should I compile the complete theory of real analysis [Y/N, default is Y] ?"
+ read reals_ans
+
+ case $reals_ans in
+ "N"|"n"|"No"|"NO"|"no")
+ reals=basic;;
+ *) reals=all;;
+ esac;;
+ yes) true;;
+esac
+
+# case $emacs_spec in
+# no) echo "Which Emacs command should I use to compile coq.el [$emacs_def] ?"
+# read EMACS
+
+# case $EMACS in
+# "") EMACS=$emacs_def;;
+# *) true;;
+# esac;;
+# yes) EMACS=$emacs;;
+# esac
+
+###########################################
# Summary of the configuration
echo ""
@@ -460,16 +483,19 @@ echo ""
# Building the $COQTOP/config/coq_config.ml file
#####################################################
-# damned backslashes under M$Windows
-case $ARCH in
- win32)
- CAMLLIB=`echo $CAMLLIB |sed -e 's|\\\|\\\\\\\|g'`
- BINDIR=`echo $BINDIR |sed -e 's|\\\|\\\\\\\|g'`
- LIBDIR=`echo $LIBDIR |sed -e 's|\\\|\\\\\\\|g'`
- MANDIR=`echo $MANDIR |sed -e 's|\\\|\\\\\\\|g'`
- EMACSLIB=`echo $EMACSLIB |sed -e 's|\\\|\\\\\\\|g'`
- ;;
-esac
+# An escaped version of a variable
+escape_var () {
+ocaml 2>&1 1>/dev/null <<EOF
+ prerr_endline(String.escaped(Sys.getenv"$VAR"));;
+EOF
+}
+
+export COQTOP BINDIR LIBDIR CAMLLIB
+ESCCOQTOP="`VAR=COQTOP escape_var`"
+ESCBINDIR="`VAR=BINDIR escape_var`"
+ESCLIBDIR="`VAR=LIBDIR escape_var`"
+ESCCAMLLIB="`VAR=CAMLLIB escape_var`"
+ESCCAMLP4LIB="$ESCCAMLLIB"/camlp4
mlconfig_file=$COQTOP/config/coq_config.ml
rm -f $mlconfig_file
@@ -477,11 +503,11 @@ cat << END_OF_COQ_CONFIG > $mlconfig_file
(* DO NOT EDIT THIS FILE: automatically generated by ../configure *)
let local = $local
-let bindir = "$BINDIR"
-let coqlib = "$LIBDIR"
-let coqtop = "$COQTOP"
-let camllib = "$CAMLLIB"
-let camlp4lib = "$CAMLP4LIB"
+let bindir = "$ESCBINDIR"
+let coqlib = "$ESCLIBDIR"
+let coqtop = "$ESCCOQTOP"
+let camllib = "$ESCCAMLLIB"
+let camlp4lib = "$ESCCAMLP4LIB"
let best = "$best_compiler"
let arch = "$ARCH"
let osdeplibs = "$OSDEPLIBS"
@@ -522,29 +548,40 @@ rm -f $COQTOP/config/Makefile
# damned backslashes under M$Windows (bis)
case $ARCH in
win32)
- BINDIR=`echo $BINDIR |sed -e 's|\\\|\\\\\\\|g'`
- LIBDIR=`echo $LIBDIR |sed -e 's|\\\|\\\\\\\|g'`
- MANDIR=`echo $MANDIR |sed -e 's|\\\|\\\\\\\|g'`
- EMACSLIB=`echo $EMACSLIB |sed -e 's|\\\|\\\\\\\|g'`
+ ESCCOQTOP=`echo $COQTOP |sed -e 's|\\\|\\\\\\\|g'`
+ ESCBINDIR=`echo $BINDIR |sed -e 's|\\\|\\\\\\\|g'`
+ ESCLIBDIR=`echo $LIBDIR |sed -e 's|\\\|\\\\\\\|g'`
+ ESCMANDIR=`echo $MANDIR |sed -e 's|\\\|\\\\\\\|g'`
+ ESCEMACSLIB=`echo $EMACSLIB |sed -e 's|\\\|\\\\\\\|g'`
+ ESCCOQDOCDIR=`echo $COQDOCDIR |sed -e 's|\\\|\\\\\\\|g'`
+ ESCCAMLP4BIN=`echo $CAMLP4BIN |sed -e 's|\\\|\\\\\\\|g'`
;;
+ *)
+ ESCCOQTOP="$COQTOP"
+ ESCBINDIR="$BINDIR"
+ ESCLIBDIR="$LIBDIR"
+ ESCMANDIR="$MANDIR"
+ ESCEMACSLIB="$EMACSLIB"
+ ESCCOQDOCDIR="$COQDOCDIR"
+ ESCCAMLP4BIN="$CAMLP4BIN" ;;
esac
sed -e "s|LOCALINSTALLATION|$local|" \
- -e "s|COQTOPDIRECTORY|$COQTOP|" \
+ -e "s|COQTOPDIRECTORY|$ESCCOQTOP|" \
-e "s|COQVERSION|$VERSION|" \
- -e "s|BINDIRDIRECTORY|$BINDIR|" \
- -e "s|COQLIBDIRECTORY|$LIBDIR|" \
- -e "s|MANDIRDIRECTORY|$MANDIR|" \
- -e "s|EMACSLIBDIRECTORY|$EMACSLIB|" \
+ -e "s|BINDIRDIRECTORY|$ESCBINDIR|" \
+ -e "s|COQLIBDIRECTORY|$ESCLIBDIR|" \
+ -e "s|MANDIRDIRECTORY|$ESCMANDIR|" \
+ -e "s|EMACSLIBDIRECTORY|$ESCEMACSLIB|" \
-e "s|EMACSCOMMAND|$EMACS|" \
- -e "s|COQDOCDIRECTORY|$COQDOCDIR|" \
+ -e "s|COQDOCDIRECTORY|$ESCCOQDOCDIR|" \
-e "s|MKTEXLSRCOMMAND|$MKTEXLSR|" \
-e "s|ARCHITECTURE|$ARCH|" \
-e "s|OSDEPENDENTLIBS|$OSDEPLIBS|" \
-e "s|OSDEPENDENTP4OPTFLAGS|$OSDEPP4OPTFLAGS|" \
-e "s|CAMLLIBDIRECTORY|$CAMLLIB|" \
-e "s|CAMLTAG|$CAMLTAG|" \
- -e "s|CAMLP4BINDIRECTORY|$CAMLP4BIN|" \
+ -e "s|CAMLP4BINDIRECTORY|$ESCCAMLP4BIN|" \
-e "s|CAMLP4LIBDIRECTORY|$CAMLP4LIB|" \
-e "s|CAMLP4TOOL|$camlp4o|" \
-e "s|CAMLP4COMPATFLAGS|$CAMLP4COMPAT|" \
@@ -602,4 +639,4 @@ echo
echo "*Warning* To compile the system for a new architecture"
echo " don't forget to do a 'make archclean' before './configure'."
-# $Id: configure 8932 2006-06-09 09:29:03Z notin $
+# $Id: configure 8961 2006-06-15 15:22:05Z notin $