summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2008-08-08 13:18:42 +0200
committerGravatar Stephane Glondu <steph@glondu.net>2008-08-08 13:18:42 +0200
commit870075f34dd9fa5792bfbf413afd3b96f17e76a0 (patch)
tree0c647056de1832cf1dba5ba58758b9121418e4be /configure
parenta0cfa4f118023d35b767a999d5a2ac4b082857b4 (diff)
Imported Upstream version 8.2~beta4+dfsgupstream/8.2.beta4+dfsg
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure68
1 files changed, 63 insertions, 5 deletions
diff --git a/configure b/configure
index 59cfcb9f..2747ee2f 100755
--- a/configure
+++ b/configure
@@ -6,8 +6,10 @@
#
##################################
-VERSION=8.2beta3
-DATE="Jun. 2008"
+VERSION=8.2beta4
+VOMAGIC=08193
+STATEMAGIC=19764
+DATE="Aug. 2008"
# a local which command for sh
which () {
@@ -23,7 +25,7 @@ done
}
usage () {
- echo "Available options for configure are:\n"
+ printf "Available options for configure are:\n"
echo "-help"
printf "\tDisplays this help page\n"
echo "-prefix <dir>"
@@ -57,6 +59,10 @@ usage () {
printf "\tSpecifies whether or not to compile full FSets/Reals library\n"
echo "-coqide (opt|byte|no)"
printf "\tSpecifies whether or not to compile Coqide\n"
+ echo "-browser <command>"
+ printf "\tUse <command> to open URL %%s\n"
+ echo "-with-doc (yes|no)"
+ printf "\tSpecifies whether or not to compile the documentation\n"
echo "-with-geoproof (yes|no)"
printf "\tSpecifies whether or not to use Geoproof binding\n"
echo "-with-cc <file>"
@@ -113,7 +119,10 @@ fsets=all
reals=all
arch_spec=no
coqide_spec=no
+browser_spec=no
with_geoproof=false
+with_doc=all
+with_doc_spec=no
COQSRC=`pwd`
@@ -183,6 +192,15 @@ while : ; do
*) COQIDE=no
esac
shift;;
+ -browser|--browser) browser_spec=yes
+ BROWSER=$2
+ shift;;
+ -with-doc|--with-doc) with_doc_spec=yes
+ case "$2" in
+ yes|all) with_doc=all;;
+ *) with_doc=no
+ esac
+ shift;;
-with-geoproof|--with-geoproof)
case $2 in
yes) with_geoproof=true;;
@@ -321,6 +339,15 @@ else
echo "Cannot find GNU Make 3.81"
fi
+# Browser command
+
+if [ "$browser_spec" = "no" ]; then
+ case $ARCH in
+ win32) BROWSER='C:\PROGRA~1\INTERN~1\IEXPLORE %s' ;;
+ *) BROWSER='firefox -remote "OpenURL(%s,new-tab)" || firefox %s &' ;;
+ esac
+fi
+
#########################################
# Objective Caml programs
@@ -594,6 +621,24 @@ esac
# "") MKTEXLSR=true;;
#esac
+# "
+### Test if documentation can be compiled (latex, hevea)
+
+if test "$with_doc" = "all"
+then
+ if test "`which latex`" = ""
+ then
+ echo "latex was not found; documentation will not be available"
+ with_doc=no
+ else
+ if test "`which hevea`" = ""
+ then
+ with_doc=no
+ echo "hevea was not found: documentation will not be available"
+ fi
+ fi
+fi
+
###########################################
# bindir, libdir, mandir, docdir, etc.
@@ -747,7 +792,13 @@ echo " Reals theory : All"
else
echo " Reals theory : Basic"
fi
+if test "$with_doc" = "all"; then
+echo " Documentation : All"
+else
+echo " Documentation : None"
+fi
echo " CoqIde : $COQIDE"
+echo " Web browser : $BROWSER"
echo ""
echo " Paths for true installation:"
@@ -769,6 +820,10 @@ escape_var () {
EOF
}
+# Escaped version of browser command
+export BROWSER
+ESCBROWSER=`VAR=BROWSER escape_var`
+
# damned backslashes under M$Windows
case $ARCH in
win32)
@@ -818,11 +873,13 @@ let best = "$best_compiler"
let arch = "$ARCH"
let osdeplibs = "$OSDEPLIBS"
let version = "$VERSION"
-let versionsi = "$VERSIONSI"
let date = "$DATE"
let compile_date = "$COMPILEDATE"
+let vo_magic_number = $VOMAGIC
+let state_magic_number = $STATEMAGIC
let exec_extension = "$EXE"
let with_geoproof = ref $with_geoproof
+let browser = "$ESCBROWSER"
END_OF_COQ_CONFIG
@@ -895,6 +952,7 @@ sed -e "s|LOCALINSTALLATION|$local|" \
-e "s|REALSOPT|$reals|" \
-e "s|COQIDEOPT|$COQIDE|" \
-e "s|CHECKEDOUTSOURCETREE|$checkedout|" \
+ -e "s|WITHDOCOPT|$with_doc|" \
"$COQSRC/config/Makefile.template" > "$COQSRC/config/Makefile"
chmod a-w "$COQSRC/config/Makefile"
@@ -936,4 +994,4 @@ echo
echo "*Warning* To compile the system for a new architecture"
echo " don't forget to do a 'make archclean' before './configure'."
-# $Id: configure 11181 2008-06-27 07:35:45Z notin $
+# $Id: configure 11320 2008-08-07 19:40:59Z notin $