summaryrefslogtreecommitdiff
path: root/config
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2008-07-25 15:12:53 +0200
committerGravatar Samuel Mimram <smimram@debian.org>2008-07-25 15:12:53 +0200
commita0cfa4f118023d35b767a999d5a2ac4b082857b4 (patch)
treedabcac548e299fee1da464c93b3dba98484f45b1 /config
parent2281410e38ef99d025ea77194585a9bc019fdaa9 (diff)
Imported Upstream version 8.2~beta3+dfsgupstream/8.2.beta3+dfsg
Diffstat (limited to 'config')
-rw-r--r--config/Makefile.template16
-rw-r--r--config/coq_config.mli2
2 files changed, 13 insertions, 5 deletions
diff --git a/config/Makefile.template b/config/Makefile.template
index 1e611356..e5061ebe 100644
--- a/config/Makefile.template
+++ b/config/Makefile.template
@@ -15,6 +15,9 @@
#
#############################################################################
+#Variable used to detect whether ./configure has run successfully.
+COQ_CONFIGURED=yes
+
# Local use (no installation)
LOCAL=LOCALINSTALLATION
@@ -27,6 +30,7 @@ LOCAL=LOCALINSTALLATION
BINDIR="BINDIRDIRECTORY"
COQLIB="COQLIBDIRECTORY"
MANDIR="MANDIRDIRECTORY"
+DOCDIR="DOCDIRDIRECTORY"
EMACSLIB="EMACSLIBDIRECTORY"
EMACS=EMACSCOMMAND
@@ -52,6 +56,7 @@ MYCAMLP4LIB="CAMLP4LIBDIRECTORY"
COQIDEINCLUDES=LABLGTKINCLUDES
# Objective-Caml compile command
+OCAML="OCAMLEXEC"
OCAMLC="BYTECAMLC"
OCAMLOPT="NATIVECAMLC"
OCAMLDEP="OCAMLDEPEXEC"
@@ -67,11 +72,9 @@ CAMLMKTOP="CAMLMKTOPEXEC"
# Caml flags
CAMLFLAGS=-rectypes CAMLANNOTATEFLAG
-# Compilation debug flag
+# Compilation debug flags
CAMLDEBUG=COQDEBUGFLAG
-
-# Inlining flag (inlining causes problems with ocaml < 3.09.x)
-INLINEFLAG=COQINLINEFLAG
+CAMLDEBUGOPT=COQDEBUGFLAGOPT
# User compilation flag
USERFLAGS=
@@ -133,6 +136,11 @@ HASCOQIDE=COQIDEOPT
# Defining REVISION
CHECKEDOUT=CHECKEDOUTSOURCETREE
+# Defining options to generate dependencies graphs
+DOT=dot
+DOTOPTS=-Tps
+ODOCDOTOPTS=-dot -dot-reduce
+
# make or sed are bogus and believe lines not terminating by a return
# are inexistent
diff --git a/config/coq_config.mli b/config/coq_config.mli
index bf77f0f3..23d3efbd 100644
--- a/config/coq_config.mli
+++ b/config/coq_config.mli
@@ -6,7 +6,7 @@
(* * GNU Lesser General Public License Version 2.1 *)
(************************************************************************)
-(*i $Id: coq_config.mli 10185 2007-10-06 18:05:13Z herbelin $ i*)
+(*i $Id: coq_config.mli 10122 2007-09-15 10:35:59Z letouzey $ i*)
val local : bool (* local use (no installation) *)