summaryrefslogtreecommitdiff
path: root/config
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2010-07-21 09:46:51 +0200
committerGravatar Stephane Glondu <steph@glondu.net>2010-07-21 09:46:51 +0200
commit5b7eafd0f00a16d78f99a27f5c7d5a0de77dc7e6 (patch)
tree631ad791a7685edafeb1fb2e8faeedc8379318ae /config
parentda178a880e3ace820b41d38b191d3785b82991f5 (diff)
Imported Upstream snapshot 8.3~beta0+13298
Diffstat (limited to 'config')
-rw-r--r--config/Makefile.template9
-rw-r--r--config/coq_config.mli25
-rw-r--r--config/giveostype.ml1
3 files changed, 25 insertions, 10 deletions
diff --git a/config/Makefile.template b/config/Makefile.template
index 4d45f1b4..74ec9580 100644
--- a/config/Makefile.template
+++ b/config/Makefile.template
@@ -135,15 +135,12 @@ COQDOCDIR="COQDOCDIRECTORY"
# Win32 systems: true (actually strip is bogus)
STRIP=STRIPCOMMAND
-# Options for fsets (all/basic)
-FSETS=FSETSOPT
-
-# Options for reals (all/basic)
-REALS=REALSOPT
-
# CoqIde (no/byte/opt)
HASCOQIDE=COQIDEOPT
+# IM files
+UIMSCRIPTDIR=UIMSCRIPTPATH
+
# Defining REVISION
CHECKEDOUT=CHECKEDOUTSOURCETREE
diff --git a/config/coq_config.mli b/config/coq_config.mli
index 0dc4a6a8..2cd1e454 100644
--- a/config/coq_config.mli
+++ b/config/coq_config.mli
@@ -6,19 +6,33 @@
(* * GNU Lesser General Public License Version 2.1 *)
(************************************************************************)
-(*i $Id: coq_config.mli 12104 2009-04-24 18:10:10Z notin $ i*)
+(*i $Id$ i*)
val local : bool (* local use (no installation) *)
val coqlib : string (* where the std library is installed *)
val coqsrc : string (* where are the sources *)
+val ocaml : string (* names of ocaml binaries *)
+val ocamlc : string
+val ocamlopt : string
+val ocamlmklib : string
+val ocamldoc : string
+val ocamldep : string
+val ocamlyacc : string
+val ocamllex : string
+
val camlbin : string (* base directory of OCaml binaries *)
val camllib : string (* for Dynlink *)
val camlp4 : string (* exact name of camlp4: either "camlp4" ou "camlp5" *)
+val camlp4o : string (* name of the camlp4o/camlp5o executable *)
val camlp4bin : string (* base directory for Camlp4/5 binaries *)
val camlp4lib : string (* where is the library of Camlp4 *)
+val camlp4compat : string (* compatibility argument to camlp4/5 *)
+
+val coqideincl : string (* arguments for building coqide (e.g. lablgtk) *)
+val cflags : string (* arguments passed to gcc *)
val best : string (* byte/opt *)
val arch : string (* architecture *)
@@ -36,7 +50,7 @@ val vo_magic_number : int
val state_magic_number : int
val theories_dirs : string list
-val contrib_dirs : string list
+val plugins_dirs : string list
val exec_extension : string (* "" under Unix, ".exe" under MS-windows *)
val with_geoproof : bool ref (* to (de)activate functions specific to Geoproof with Coqide *)
@@ -45,8 +59,13 @@ val browser : string
(** default web browser to use, may be overriden by environment
variable COQREMOTEBROWSER *)
+val has_coqide : string
+
+val has_natdynlink : bool
+val natdynlinkflag : string (* special cases of natdynlink (e.g. MacOS 10.5) *)
+
val wwwcoq : string
val wwwrefman : string
val wwwstdlib : string
+val localwwwrefman : string
-val has_natdynlink : bool
diff --git a/config/giveostype.ml b/config/giveostype.ml
deleted file mode 100644
index e657bc79..00000000
--- a/config/giveostype.ml
+++ /dev/null
@@ -1 +0,0 @@
-print_string Sys.os_type;;