summaryrefslogtreecommitdiff
path: root/Makefile.doc
diff options
context:
space:
mode:
authorGravatar Enrico Tassi <gareuselesinge@debian.org>2015-07-15 10:36:12 +0200
committerGravatar Enrico Tassi <gareuselesinge@debian.org>2015-07-15 10:36:12 +0200
commit0aa2544d04dbd4b6ee665b551ed165e4fb02d2fa (patch)
tree12e8931a4a56da1a1bdfb89d670f4ba38fe08e1f /Makefile.doc
parentcec4741afacd2e80894232850eaf9f9c0e45d6d7 (diff)
Imported Upstream version 8.5~beta2+dfsgupstream/8.5_beta2+dfsg
Diffstat (limited to 'Makefile.doc')
-rw-r--r--Makefile.doc14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile.doc b/Makefile.doc
index bc6ae020..1f350935 100644
--- a/Makefile.doc
+++ b/Makefile.doc
@@ -53,7 +53,7 @@ ifdef QUICK
%.v.tex: %.tex
$(COQTEX) $(COQTEXOPTS) $<
else
-%.v.tex: %.tex $(COQTEX) $(COQTOPEXE) $(PLUGINSVO) $(THEORIESVO)
+%.v.tex: %.tex $(COQTEX) $(COQTOPEXE) $(ALLVO)
$(COQTEX) $(COQTEXOPTS) $<
endif
@@ -99,6 +99,8 @@ doc/refman/Reference-Manual.dvi: $(REFMANFILES) doc/refman/Reference-Manual.tex
$(SHOWMAKEINDEXERROR) Reference-Manual.ilg;\
$(MAKEINDEX) -q Reference-Manual.comidx -o Reference-Manual.comind;\
$(SHOWMAKEINDEXERROR) Reference-Manual.ilg;\
+ $(MAKEINDEX) -q Reference-Manual.optidx -o Reference-Manual.optind;\
+ $(SHOWMAKEINDEXERROR) Reference-Manual.ilg;\
$(MAKEINDEX) -q Reference-Manual.erridx -o Reference-Manual.errind;\
$(SHOWMAKEINDEXERROR) Reference-Manual.ilg;\
$(LATEX) -interaction=batchmode Reference-Manual > /dev/null;\
@@ -202,12 +204,12 @@ doc/faq/html/index.html: doc/faq/FAQ.v.html
ifdef QUICK
doc/stdlib/html/genindex.html:
else
-doc/stdlib/html/genindex.html: | $(COQDOC) $(THEORIESVO)
+doc/stdlib/html/genindex.html: | $(COQDOC) $(ALLVO)
endif
- rm -rf doc/stdlib/html
$(MKDIR) doc/stdlib/html
$(COQDOC) -q -d doc/stdlib/html --with-header doc/common/styles/html/$(HTMLSTYLE)/header.html --with-footer doc/common/styles/html/$(HTMLSTYLE)/footer.html --multi-index --html -g \
- -R theories Coq $(THEORIESVO:.vo=.v)
+ -R theories Coq -R plugins Coq $(VFILES)
mv doc/stdlib/html/index.html doc/stdlib/html/genindex.html
doc/stdlib/index-list.html: doc/stdlib/index-list.html.template doc/stdlib/make-library-index
@@ -246,12 +248,12 @@ doc/stdlib/FullLibrary.tex: doc/stdlib/Library.tex
ifdef QUICK
doc/stdlib/FullLibrary.coqdoc.tex:
$(COQDOC) -q -boot --gallina --body-only --latex --stdout --utf8 \
- -R theories Coq $(THEORIESVO:.vo=.v) > $@
+ -R theories Coq -R plugins Coq $(VFILES) > $@
sed -i.tmp -e 's///g' $@ && rm $@.tmp
else
-doc/stdlib/FullLibrary.coqdoc.tex: $(COQDOC) $(THEORIESVO)
+doc/stdlib/FullLibrary.coqdoc.tex: $(COQDOC) $(ALLVO)
$(COQDOC) -q -boot --gallina --body-only --latex --stdout --utf8 \
- -R theories Coq $(THEORIESVO:.vo=.v) > $@
+ -R theories Coq -R plugins Coq $(VFILES) > $@
sed -i.tmp -e 's///g' $@ && rm $@.tmp
endif