summaryrefslogtreecommitdiff
path: root/Makefile.dep
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2004-07-28 21:54:47 +0000
committerGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2004-07-28 21:54:47 +0000
commit6b649aba925b6f7462da07599fe67ebb12a3460e (patch)
tree43656bcaa51164548f3fa14e5b10de5ef1088574 /Makefile.dep
Imported Upstream version 8.0pl1upstream/8.0pl1
Diffstat (limited to 'Makefile.dep')
-rw-r--r--Makefile.dep15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.dep b/Makefile.dep
new file mode 100644
index 00000000..30690fac
--- /dev/null
+++ b/Makefile.dep
@@ -0,0 +1,15 @@
+#######################################################################
+# v # The Coq Proof Assistant / The Coq Development Team #
+# <O___,, # INRIA-Rocquencourt & LRI-CNRS-Orsay #
+# \VV/ #############################################################
+# // # This file is distributed under the terms of the #
+# # GNU Lesser General Public License Version 2.1 #
+#######################################################################
+
+# This Makefile is designed to make the .ml files corresponding to .ml4 files
+
+include Makefile
+include .depend.camlp4
+
+.ml4.ml:
+ $(CAMLP4O) $(CAMLP4EXTENDFLAGS) pr_o.cmo `$(CAMLP4DEPS) $<` -impl $< > $@ || rm -f $@