summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2009-08-29 16:55:03 +0200
committerGravatar Stephane Glondu <steph@glondu.net>2009-08-29 16:59:16 +0200
commitd8e2663f7445de8536e71e16655bd083806360c1 (patch)
tree491490c95051dd6f87d3357d3ef399d9de47b134
parent52af446e4104d711a4fce53438b4bd29920a5e3d (diff)
Various updates, prepare upload to unstabledebian/8.2.pl1+dfsg-3
-rw-r--r--debian/README.source13
-rw-r--r--debian/changelog13
-rw-r--r--debian/control7
-rwxr-xr-xdebian/rules16
4 files changed, 34 insertions, 15 deletions
diff --git a/debian/README.source b/debian/README.source
index a88c4753..b1b16335 100644
--- a/debian/README.source
+++ b/debian/README.source
@@ -25,8 +25,14 @@ version (the script will do it for you).
Patch system
------------
-This package uses dpatch for patching the source. Please consider
-reading dpatch manpage to patch the source.
+This source package uses quilt to apply and remove its patches. Please
+refer to `/usr/share/doc/quilt/README.source' for information about
+how to use quilt for source packages.
+
+The quilt series is generated from the Git repository, using
+dom-{apply,save}-patches, from the dh-ocaml (>= 0.5) package. Please
+refer to the appendix about Git in the Debian OCaml Packaging Policy
+(from the same package).
Version Control System
@@ -47,3 +53,6 @@ Since Coq takes so much time to compile, there is a build cache to
speed-up Debian development and debugging. Just copy a previous build
to ../coq.cache, and debian/rules will detect its presence and rsync
from there instead of really compiling Coq...
+
+
+ -- Stéphane Glondu <glondu@debian.org>, Sat, 29 Aug 2009 16:49:52 +0200
diff --git a/debian/changelog b/debian/changelog
index 7c61421e..62aa501f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,15 @@
-coq (8.2.pl1+dfsg-3) UNRELEASED; urgency=low
+coq (8.2.pl1+dfsg-3) unstable; urgency=low
* Update README.Debian (Closes: #538398)
-
- -- Stephane Glondu <steph@glondu.net> Sat, 25 Jul 2009 16:31:48 +0200
+ * Add 0001-Update-for-why-2.19.patch
+ * debian/control:
+ - update my e-mail address and remove DMUA
+ - add why to Suggests
+ - add quilt to Build-Depends
+ - update Standards-Version to 3.8.3 (no changes)
+ * Update README.source to reflect use of quilt
+
+ -- Stéphane Glondu <glondu@debian.org> Sat, 29 Aug 2009 16:58:45 +0200
coq (8.2.pl1+dfsg-2) unstable; urgency=low
diff --git a/debian/control b/debian/control
index dd90f964..1a8784a8 100644
--- a/debian/control
+++ b/debian/control
@@ -7,11 +7,11 @@ Uploaders:
Remi Vanicat <vanicat@debian.org>,
Stefano Zacchiroli <zack@debian.org>,
Samuel Mimram <smimram@debian.org>,
- Stephane Glondu <steph@glondu.net>
-DM-Upload-Allowed: yes
-Standards-Version: 3.8.2
+ Stéphane Glondu <glondu@debian.org>
+Standards-Version: 3.8.3
Build-Depends:
debhelper (>= 7),
+ quilt (>= 0.46-7~),
dpkg-dev (>= 1.13.19),
dh-ocaml (>= 0.4.1),
ocaml-nox (>= 3.11.0-5),
@@ -39,6 +39,7 @@ Suggests:
proofgeneral-coq,
ledit | readline-editor,
libcoq-ocaml-dev,
+ why (>= 2.19),
coq-doc
Conflicts: coq-libs
Replaces: coq-libs
diff --git a/debian/rules b/debian/rules
index 0dcf678e..71b8d68c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -35,9 +35,11 @@ OCAMLINIT_SED += \
-e 's%@CoqVersion@%$(COQ_VERSION)%' \
-e 's%@CoqABI@%$(COQ_ABI)%'
+DH := dh --with quilt
+
configure: configure-stamp
configure-stamp: ocamlinit-stamp
- dh build --before dh_auto_configure
+ $(DH) build --before dh_auto_configure
./configure $(CONFIGUREOPTS)
touch $@
@@ -56,12 +58,12 @@ ifeq ($(BUILDCACHE),)
else
rsync -a --exclude=debian --exclude=.git $(BUILDCACHE)/ .
endif
- dh build --after dh_auto_test
+ $(DH) build --after dh_auto_test
touch $@
install: install-stamp
install-stamp: build-stamp
- dh install --before dh_auto_install
+ $(DH) install --before dh_auto_install
$(MAKE) $(ADDPREF) install
find debian/tmp -regextype posix-awk \
-regex '.*\.(cm[aoxi]|cmxa|[ao])$$' \
@@ -74,7 +76,7 @@ install-stamp: build-stamp
cp debian/coqide.desktop debian/coqide/usr/share/applications
cp -r doc/stdlib/html debian/coq-theories/usr/share/doc/coq-theories/
cp debian/coqvars.mk debian/coq/usr/share/coq/
- dh install --after dh_install
+ $(DH) install --after dh_install
for u in $(PACKAGES); do \
echo 'F:OCamlABI=$(OCAML_ABI)' >> debian/$$u.substvars; \
echo 'F:CoqABI=$(COQ_ABI)' >> debian/$$u.substvars; \
@@ -82,13 +84,13 @@ install-stamp: build-stamp
touch $@
clean: ocamlinit-clean
- dh $@
+ $(DH) $@
binary-indep: install-stamp
- dh $@
+ $(DH) $@
binary-arch: install-stamp
- dh $@
+ $(DH) $@
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure ocamlinit