summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@debian.org>2018-12-29 15:17:06 -0500
committerGravatar Benjamin Barenblat <bbaren@debian.org>2019-01-03 18:24:41 -0500
commita946e9959296cedf2540622c1b332a3ccbee4009 (patch)
tree8a728ab6273e8eb5c122337fac76782a0756451a
parente23d443a3a64b30a77e8ea92f347f933a865bb99 (diff)
Explicitly build and install OCaml bytecode files
Bytecode is no longer built by default, but it’s still essential on Debian platforms where OCaml has no native compiler. Run `make byte` and `make install-byte` to install bytecode. In the future, we may want to separate bytecode binaries and libraries into their own packages so users on platforms with native support don’t have to spend disk space on bytecode. For now, though, continue bundling native code and bytecode into the same package.
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 8c97cf17..db2ddc0f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -65,7 +65,10 @@ ifeq ($(BUILDCACHE),)
# the default one without -silent (-silent maybe cause buildd to
# timeout because of lack of output)
+# Don't combine `make world` and `make byte`--doing so triggers a race
+# in the build system. See upstream's CHANGES.
$(MAKE) world STRIP=true
+ $(MAKE) byte STRIP=true
$(MAKE) DOC_TARGETS=$(HTMLDOC) $(HTMLDOC)
else
rsync -a --exclude=debian --exclude=.git $(BUILDCACHE)/ .
@@ -84,7 +87,7 @@ override_dh_auto_test:
.PHONY: override_dh_auto_install
override_dh_auto_install:
- $(MAKE) $(ADDPREF) install
+ $(MAKE) $(ADDPREF) install install-byte
find debian/tmp -regextype posix-awk \
-regex '.*\.(cmi|cmx|cmxa|[ao])$$' \
| grep -v toploop/ | grep -v coq-native \