summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2006-04-30 11:55:37 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2006-04-30 11:55:37 +0000
commit8d68c744369bd248748f10927f01b054595d102c (patch)
tree623c9a80a330db05ed34add0ca4d0fd18e5ce601
parentc514a452ff3ba2980ddd5a4b2f795af361b3c101 (diff)
Added makefile.dpatch in order for ocamlopt not to be called when compiling on non-native archs.
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/makefile.dpatch20
3 files changed, 28 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index c73a4116..50bad72f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+coq (8.0pl3+8.1alpha-2) UNRELEASED; urgency=low
+
+ * Added makefile.dpatch in order for ocamlopt not to be called when
+ compiling on non-native archs.
+
+ -- Samuel Mimram <smimram@debian.org> Sun, 30 Apr 2006 11:51:57 +0000
+
coq (8.0pl3+8.1alpha-1) experimental; urgency=low
* New upstream release.
diff --git a/debian/patches/00list b/debian/patches/00list
index 1fbe17e1..55a135be 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,3 +1,4 @@
coqdoc_stdlib
failing_tests
browser
+makefile
diff --git a/debian/patches/makefile.dpatch b/debian/patches/makefile.dpatch
new file mode 100755
index 00000000..b656a9bb
--- /dev/null
+++ b/debian/patches/makefile.dpatch
@@ -0,0 +1,20 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## makefile.dpatch by Samuel Mimram <smimram@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Do not use ocamlopt to test grammar.cma, we don't want to use ocamlopt
+## DP: when compiling on non-native archs.
+
+@DPATCH@
+diff -urNad coq-8.0pl3+8.1alpha~/Makefile coq-8.0pl3+8.1alpha/Makefile
+--- coq-8.0pl3+8.1alpha~/Makefile 2006-04-07 15:08:12.000000000 +0000
++++ coq-8.0pl3+8.1alpha/Makefile 2006-04-30 11:41:09.000000000 +0000
+@@ -1401,7 +1401,7 @@
+ parsing/grammar.cma: $(GRAMMARCMO)
+ $(SHOW)'Testing $@'
+ @touch test.ml4
+- $(HIDE)$(OCAMLOPT) $(OPTFLAGS) -pp "$(CAMLP4O) $(CAMLP4EXTENDFLAGS) $(GRAMMARCMO) -impl" -impl test.ml4 -o test-grammar
++ $(HIDE)$(OCAMLC) $(BYTEFLAGS) -pp "$(CAMLP4O) $(CAMLP4EXTENDFLAGS) $(GRAMMARCMO) -impl" -impl test.ml4 -o test-grammar
+ @rm -f test-grammar test.*
+ $(SHOW)'OCAMLC -a $@'
+ $(HIDE)$(OCAMLC) $(BYTEFLAGS) $(GRAMMARCMO) -linkall -a -o $@