summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Stephane Glondu <steph@glondu.net>2011-02-26 17:56:07 +0100
committerGravatar Stephane Glondu <steph@glondu.net>2011-02-26 18:12:14 +0100
commit853081b70ac141ffcbde0cf468b6f45c62f0a964 (patch)
tree01ac4de6d832b6c4766c2bcb8a134645b35281b7
parentfd881d28abea04fa7f4613054903129c7a633dbf (diff)
Set and check COQ_VERSION used to compute COQ_ABI in debian/rulesdebian/8.3.pl1+dfsg-2
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules8
2 files changed, 13 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index d87646b5..4c4a8390 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+coq (8.3.pl1+dfsg-2) experimental; urgency=low
+
+ * Set and check COQ_VERSION used to compute COQ_ABI in debian/rules
+
+ -- Stéphane Glondu <glondu@debian.org> Sat, 26 Feb 2011 18:12:12 +0100
+
coq (8.3.pl1+dfsg-1) experimental; urgency=low
* New upstream release
diff --git a/debian/rules b/debian/rules
index 3471198a..a4609b76 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,7 +22,7 @@ ADDPREF := COQINSTALLPREFIX=$(COQPREF) OLDROOT=
PACKAGES := $(shell dh_listpackages)
-COQ_VERSION := $(shell dpkg-parsechangelog | sed -n -e 's/~/+/g' -e 's/^Version: \(.*\)-[0-9]\+/\1/p')
+COQ_VERSION := 8.3pl1
COQ_ABI := $(COQ_VERSION)+$(OCAML_ABI)
CONFIGUREOPTS := --arch Linux --prefix /usr --mandir /usr/share/man \
@@ -60,6 +60,12 @@ ifeq ($(BUILDCACHE),)
else
rsync -a --exclude=debian --exclude=.git $(BUILDCACHE)/ .
endif
+# Check that $(COQ_VERSION) has the right value
+ ACTUAL_COQ_VERSION="$$(./bin/coqc --version | awk '/version/{print $$6}')"; \
+ if [ "$$ACTUAL_COQ_VERSION" != "$(COQ_VERSION)" ]; then \
+ echo "Please set COQ_VERSION to $$ACTUAL_COQ_VERSION in debian/rules"; \
+ exit 2; \
+ fi
.PHONY: override_dh_auto_test
override_dh_auto_test: