summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2007-11-29 14:02:40 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2007-11-29 14:02:40 +0000
commit61fca4c1e9271b8b5d8c90589e0c89991871a8a6 (patch)
tree886acbd7108dcfc77b2ed887000af90f39037e2a
parentff7401a4c320d5da208198caddc17b11b1bc2e56 (diff)
Added check.dpatch to remove warnings in tests.
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/check.dpatch19
3 files changed, 24 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index fd3cddc5..83c1b7bf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,10 @@
coq (8.1.pl2+dfsg-3) UNRELEASED; urgency=low
- * Add a dependency from coq to emacsen-common, closes: #435023.
+ * Added check.dpatch to remove warnings which made some tests erroneously
+ fail, closes: #452572.
+ * Added a dependency from coq to emacsen-common, closes: #435023.
- -- Samuel Mimram <smimram@debian.org> Sat, 17 Nov 2007 17:48:45 +0000
+ -- Samuel Mimram <smimram@debian.org> Thu, 29 Nov 2007 13:59:01 +0000
coq (8.1.pl2+dfsg-2) unstable; urgency=low
diff --git a/debian/patches/00list b/debian/patches/00list
index bbb91a76..bf00e3ce 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -4,3 +4,4 @@ makefile
no-complexity-test
configure
cmxa-install
+check
diff --git a/debian/patches/check.dpatch b/debian/patches/check.dpatch
new file mode 100755
index 00000000..620b18a7
--- /dev/null
+++ b/debian/patches/check.dpatch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## check.dpatch by Samuel Mimram <smimram@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Suppress warnings from tests outputs.
+
+@DPATCH@
+diff -urNad coq-8.1.pl2+dfsg~/test-suite/check coq-8.1.pl2+dfsg/test-suite/check
+--- coq-8.1.pl2+dfsg~/test-suite/check 2007-11-29 14:02:40.000000000 +0000
++++ coq-8.1.pl2+dfsg/test-suite/check 2007-11-29 14:03:39.000000000 +0000
+@@ -52,7 +52,7 @@
+ nbtests=`expr $nbtests + 1`
+ printf " "$f"..."
+ tmpoutput=`mktemp /tmp/coqcheck.XXXXXX`
+- $command $f 2>&1 | grep -v "Welcome to Coq" | grep -v "Skipping rcfile loading" > $tmpoutput
++ $command $f 2>&1 | grep -v "Welcome to Coq" | grep -v "Skipping rcfile loading" | grep -v "some rule has been masked" > $tmpoutput
+ foutput=`dirname $f`/`basename $f .v`.out
+ diff $tmpoutput $foutput >& /dev/null
+ if [ $? = 0 ]; then