summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <smimram@debian.org>2006-07-13 16:29:04 +0000
committerGravatar Samuel Mimram <smimram@debian.org>2006-07-13 16:29:04 +0000
commit600cc313b09fdb0857da49f5671f885ac53d169e (patch)
tree65cfa80857ad13602f736e937fc4562e69112216
parent1b35f6eb0e260d34c927adfff18ae2a9b6fe4001 (diff)
Check assertions in native mode too.debian/8.0pl3+8.1beta.2-1
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/assert.dpatch19
3 files changed, 22 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index cb08de50..c0ff7504 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,9 @@
coq (8.0pl3+8.1beta.2-1) experimental; urgency=low
* New upstream beta release.
+ * Added assert.dpatch to check assertions in native mode.
- -- Samuel Mimram <smimram@debian.org> Thu, 13 Jul 2006 14:27:55 +0000
+ -- Samuel Mimram <smimram@debian.org> Thu, 13 Jul 2006 16:28:24 +0000
coq (8.0pl3+8.1beta-1) experimental; urgency=low
diff --git a/debian/patches/00list b/debian/patches/00list
index cafb071e..826a242c 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,3 +1,4 @@
coqdoc_stdlib
browser
makefile
+assert
diff --git a/debian/patches/assert.dpatch b/debian/patches/assert.dpatch
new file mode 100755
index 00000000..16a62f5f
--- /dev/null
+++ b/debian/patches/assert.dpatch
@@ -0,0 +1,19 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## assert.dpatch by Samuel Mimram <smimram@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Check assertions in native mode too.
+
+@DPATCH@
+diff -urNad coq-8.0pl3+8.1beta.2~/Makefile coq-8.0pl3+8.1beta.2/Makefile
+--- coq-8.0pl3+8.1beta.2~/Makefile 2006-06-25 22:17:49.000000000 +0000
++++ coq-8.0pl3+8.1beta.2/Makefile 2006-07-13 16:27:10.000000000 +0000
+@@ -74,7 +74,7 @@
+ MLINCLUDES=$(LOCALINCLUDES) -I $(MYCAMLP4LIB)
+
+ BYTEFLAGS=$(MLINCLUDES) $(CAMLDEBUG) $(USERFLAGS)
+-OPTFLAGS=$(MLINCLUDES) $(CAMLTIMEPROF) $(USERFLAGS) -noassert
++OPTFLAGS=$(MLINCLUDES) $(CAMLTIMEPROF) $(USERFLAGS)
+ OCAMLDEP=ocamldep
+ DEPFLAGS=$(LOCALINCLUDES)
+