summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2005-09-07 19:32:56 +0000
committerGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2005-09-07 19:32:56 +0000
commit44032630776b3315fc377d287e76580de759fd47 (patch)
tree55569dc13cc71c284b8d4c9cd72afe61242a827d
parent36056e5065d0d0b9f3c442b07e7ae330289f3b9e (diff)
Switching to svn-buildpackage.debian/8.0pl2-3
Added a patch to solve the FTBFS.
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/text_view_typing_error.dpatch31
-rwxr-xr-xdebian/rules1
-rw-r--r--debian/svn-deblayout3
5 files changed, 44 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index f2a5d0c6..bb23aae2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+coq (8.0pl2-3) unstable; urgency=low
+
+ * Added text_view_typing_error patch to avoid a typing error and solve the
+ FTBFS, closes: #326740.
+ * Added forgotten call to dh_installmenu.
+
+ -- Samuel Mimram <smimram@debian.org> Wed, 7 Sep 2005 21:26:36 +0200
+
coq (8.0pl2-2) unstable; urgency=medium
* Rebuilding with OCaml 3.08.3 is necessary because of the former dependency
diff --git a/debian/patches/00list b/debian/patches/00list
index e69de29b..ea23d9d7 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -0,0 +1 @@
+text_view_typing_error
diff --git a/debian/patches/text_view_typing_error.dpatch b/debian/patches/text_view_typing_error.dpatch
new file mode 100755
index 00000000..cc37d08a
--- /dev/null
+++ b/debian/patches/text_view_typing_error.dpatch
@@ -0,0 +1,31 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## text_view_typing_error.dpatch by Samuel Mimram <smimram@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Avoid a typing error with recent versions of lablgtk2.
+
+@DPATCH@
+diff -urNad --exclude=CVS --exclude=.svn ./ide/undo.ml /tmp/dpep-work.h2rZKK/coq-8.0pl2/ide/undo.ml
+--- ./ide/undo.ml 2004-07-16 21:30:21.000000000 +0200
++++ /tmp/dpep-work.h2rZKK/coq-8.0pl2/ide/undo.ml 2005-09-07 21:19:54.000000000 +0200
+@@ -18,7 +18,7 @@
+ | Insert (s,i,l) -> Delete (s,i,l)
+ | Delete (s,i,l) -> Insert (s,i,l)
+
+-class undoable_view (tv:Gtk.text_view Gtk.obj) =
++class undoable_view (tv:[> Gtk.text_view ] Gtk.obj) =
+ let undo_lock = ref true in
+ object(self)
+ inherit GText.view tv as super
+diff -urNad --exclude=CVS --exclude=.svn ./ide/undo.mli /tmp/dpep-work.h2rZKK/coq-8.0pl2/ide/undo.mli
+--- ./ide/undo.mli 2005-01-21 18:21:33.000000000 +0100
++++ /tmp/dpep-work.h2rZKK/coq-8.0pl2/ide/undo.mli 2005-09-07 21:20:07.000000000 +0200
+@@ -10,7 +10,7 @@
+
+ (* An undoable view class *)
+
+-class undoable_view : Gtk.text_view Gtk.obj ->
++class undoable_view : [> Gtk.text_view ] Gtk.obj ->
+ object
+ inherit GText.view
+ method undo : bool
diff --git a/debian/rules b/debian/rules
index 872edde4..6d7ec28b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -99,6 +99,7 @@ binary-common:
dh_testdir
dh_testroot
dh_installdocs
+ dh_installmenu
dh_installemacsen
dh_installman
dh_installchangelogs CHANGES
diff --git a/debian/svn-deblayout b/debian/svn-deblayout
new file mode 100644
index 00000000..b849ea05
--- /dev/null
+++ b/debian/svn-deblayout
@@ -0,0 +1,3 @@
+origDir=../upstream
+origUrl=svn+ssh://svn.debian.org/svn/pkg-ocaml-maint/trunk/packages/coq/upstream
+tagsUrl=svn+ssh://svn.debian.org/svn/pkg-ocaml-maint/tags/packages/coq