summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2004-08-17 14:52:58 +0000
committerGravatar Samuel Mimram <samuel.mimram@ens-lyon.org>2004-08-17 14:52:58 +0000
commit30f134b15b162a79c294874a1f338302311ae22f (patch)
tree65d2da658abe3e58a631b948296af8c10f762d60
parent07ca48478b2dee0263dba32c83958b52bb020580 (diff)
Let's see if coqide builds in bytecode on alpha.
-rw-r--r--debian/changelog12
-rw-r--r--debian/control6
-rwxr-xr-xdebian/rules10
-rw-r--r--debian/watch2
4 files changed, 22 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 5ad2851a..ace7314a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+coq (8.0pl1-2) unstable; urgency=medium
+
+ * Changed section to math.
+ * Versionned the dependency to liblablgtk2-ocaml(-dev).
+ * If we fallback on bytecode, we also try to build coqide in bytecode (I hope
+ this will fix the FTBFS on alpha).
+ * Added a watch file.
+ * Removed the unnecessary patch an unpatch targets in the rules.
+
+ -- Samuel Mimram <samuel.mimram@ens-lyon.org> Mon, 16 Aug 2004 20:39:48 +0200
+
coq (8.0pl1-1) unstable; urgency=low
* New upstream release: finally the version without QPL-licensed files is out,
@@ -5,6 +16,7 @@ coq (8.0pl1-1) unstable; urgency=low
* Libraries are now in separate packages (coq-libs and coq7-libs).
* An additional package provides coqide.
* Built with OCaml 3.08.
+ * Thank you Martin Ellis and Julien Cristau for your help on this package.
-- Samuel Mimram <samuel.mimram@ens-lyon.org> Sun, 18 Jul 2004 01:10:24 +0200
diff --git a/debian/control b/debian/control
index 6d29cf56..1bec4341 100644
--- a/debian/control
+++ b/debian/control
@@ -1,10 +1,10 @@
Source: coq
-Section: devel
+Section: math
Priority: optional
Maintainer: Debian OCaml Maintainers <debian-ocaml-maint@lists.debian.org>
Uploaders: Ralf Treinen <treinen@debian.org>, Sven Luther <luther@debian.org>, Jerome Marant <jerome@debian.org>, Remi Vanicat <vanicat@debian.org>, Stefano Zacchiroli <zack@debian.org>, Samuel Mimram <samuel.mimram@ens-lyon.org>
Standards-Version: 3.6.1
-Build-Depends: debhelper (>= 4.0.0), ocaml-3.08, ocaml-best-compilers, liblablgtk2-ocaml-dev
+Build-Depends: debhelper (>= 4.0.0), ocaml-3.08, ocaml-best-compilers, liblablgtk2-ocaml-dev (>= 2.4.0)
Package: coq
Architecture: any
@@ -26,7 +26,7 @@ Description: Proof assistant for higher-order logic
Package: coqide
Architecture: any
-Depends: coq (>= 8.0), liblablgtk2-ocaml, ${shlibs:Depends}
+Depends: coq (>= 8.0), liblablgtk2-ocaml (>= 2.4.0), ${shlibs:Depends}
Description: Proof assistant for higher-order logic
Coq is a proof assistant for higher-order logic, which allows the
development of computer programs consistent with their formal
diff --git a/debian/rules b/debian/rules
index 40e8c9e7..a8ba9e1f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,7 +8,7 @@ CONFIGUREOPTS=--prefix /usr --mandir /usr/share/man \
--emacslib /usr/share/emacs/site-lisp/coq --reals all
configure: configure-stamp
-configure-stamp: patch
+configure-stamp:
dh_testdir
if [ -e /usr/bin/ocamlc.opt ]; \
then \
@@ -16,7 +16,7 @@ configure-stamp: patch
else \
./configure $(CONFIGUREOPTS); \
fi
- if [ `arch` = ppc ] ; then ./configure $(CONFIGUREOPTS) ; fi
+ if [ $(DEB_BUILD_ARCH) = powerpc ]; then ./configure $(CONFIGUREOPTS); fi
touch configure-stamp
build: configure-stamp build-stamp
@@ -30,7 +30,7 @@ build-stamp:
&& echo Trying to build coq in bytecode instead \
&& $(MAKE) archclean clean \
&& touch test-suite/success/debian.v8 \
- && $(MAKE) BEST=byte check \
+ && $(MAKE) BEST=byte HASCOQIDE=byte check \
&& echo NATIVE CODE COMPILATION FAILED \
&& echo Coq was built in bytecode instead); \
else \
@@ -57,7 +57,7 @@ install: build
dh_clean -k
dh_installdirs
- $(MAKE) $(ADDPREF) install || $(MAKE) BEST=byte $(ADDPREF) install
+ $(MAKE) $(ADDPREF) install || $(MAKE) BEST=byte HASCOQIDE=byte $(ADDPREF) install
for i in $(COQPREF)/usr/bin/*.opt; do strip -R .note -R .comment $$i; done
cp debian/coq.xpm debian/coq/usr/share/pixmaps/coq.xpm
@@ -88,4 +88,4 @@ binary-arch: build install
dh_builddeb
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure patch unpatch
+.PHONY: build clean binary-indep binary-arch binary install configure
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 00000000..8867705d
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,2 @@
+version=2
+ftp://ftp.inria.fr/INRIA/coq/current/coq-([0-9a-z\.]*)\.tar\.gz debian uupdate