summaryrefslogtreecommitdiff
path: root/runtime
diff options
context:
space:
mode:
Diffstat (limited to 'runtime')
-rw-r--r--runtime/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/runtime/Makefile b/runtime/Makefile
index 81df4ea..668e365 100644
--- a/runtime/Makefile
+++ b/runtime/Makefile
@@ -7,7 +7,11 @@ OBJS=i64_dtos.o i64_dtou.o i64_sar.o i64_sdiv.o i64_shl.o \
i64_udivmod.o i64_udiv.o i64_umod.o i64_utod.o i64_utof.o
LIB=libcompcert.a
+ifeq ($(strip $(HAS_RUNTIME_LIB)),true)
all: $(LIB) $(INCLUDES)
+else
+all:
+endif
$(LIB): $(OBJS)
rm -f $(LIB)
@@ -22,9 +26,13 @@ $(LIB): $(OBJS)
clean::
rm -f *.o $(LIB)
+ifeq ($(strip $(HAS_RUNTIME_LIB)),true)
install:
install -d $(LIBDIR)
install -c $(LIB) $(INCLUDES) $(LIBDIR)
+else
+install:
+endif
test/test_int64: test/test_int64.c $(LIB)
$(CC) -o $@ test/test_int64.c $(LIB)