summaryrefslogtreecommitdiff
path: root/runtime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'runtime/Makefile')
-rw-r--r--runtime/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/runtime/Makefile b/runtime/Makefile
index 5f1ddc6..ef8e21b 100644
--- a/runtime/Makefile
+++ b/runtime/Makefile
@@ -1,19 +1,27 @@
include ../Makefile.config
CFLAGS=-O1 -g -Wall
-OBJS=stdio.o calloc.o
+OBJS=stdio.o
LIB=libcompcert.a
INCLUDES=stdio.h
+ifeq ($(strip $(NEED_STDLIB_WRAPPER)),true)
+all: $(LIB) $(INCLUDES)
+else
+all:
+endif
+
$(LIB): $(OBJS)
rm -f $(LIB)
ar rcs $(LIB) $(OBJS)
-stdio.o: stdio.h
-
clean:
rm -f *.o $(LIB)
+ifeq ($(strip $(NEED_STDLIB_WRAPPER)),true)
install:
install -d $(LIBDIR)
install -c $(LIB) $(INCLUDES) $(LIBDIR)
+else
+install:
+endif