summaryrefslogtreecommitdiff
path: root/cil/ocamlutil/Makefile.ocaml.build
diff options
context:
space:
mode:
Diffstat (limited to 'cil/ocamlutil/Makefile.ocaml.build')
-rw-r--r--cil/ocamlutil/Makefile.ocaml.build50
1 files changed, 0 insertions, 50 deletions
diff --git a/cil/ocamlutil/Makefile.ocaml.build b/cil/ocamlutil/Makefile.ocaml.build
deleted file mode 100644
index 5271e46..0000000
--- a/cil/ocamlutil/Makefile.ocaml.build
+++ /dev/null
@@ -1,50 +0,0 @@
-# -*- Mode: makefile -*-
-# Copyright (c) 2001-2002,
-# George C. Necula <necula@cs.berkeley.edu>
-# Scott McPeak <smcpeak@cs.berkeley.edu>
-# Wes Weimer <weimer@cs.berkeley.edu>
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are
-# met:
-#
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-#
-# 3. The names of the contributors may not be used to endorse or promote
-# products derived from this software without specific prior written
-# permission.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
-# IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
-# TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
-# PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER
-# OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
-# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
-# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
-# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
-# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
- # Auxiliary Makefile for building Ocaml project. See the documentation in
- # the associated Makefile.ocaml for how to use this file.
- # Written by necula@cs.berkeley.edu
- #
-$(PROJECT_EXECUTABLE) : $(PROJECT_MODULES:%=$(OBJDIR)/%.$(CMO)) \
- $(PROJECT_CMODULES:%=$(OBJDIR)/%.$(CMC))
- @$(NARRATIVE) "Linking $(COMPILETOWHAT) $@ $(LINKMSG)"
- $(AT)$(CAMLLINK) -verbose -o $@ \
- $(PROJECT_LIBS:%=%.$(CMXA)) \
- $(PROJECT_LIBS:%=-cclib -l%) \
- $^
-
-
-
-
-