summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile12
-rw-r--r--cfrontend/Cexec.v7
-rw-r--r--cfrontend/SimplExpr.v6
-rw-r--r--checklink/Asm_printers.mlbin124641 -> 14826 bytes
-rw-r--r--common/Errors.v3
5 files changed, 12 insertions, 16 deletions
diff --git a/Makefile b/Makefile
index 0615215..175f773 100644
--- a/Makefile
+++ b/Makefile
@@ -17,10 +17,10 @@ DIRS=lib common $(ARCH)/$(VARIANT) $(ARCH) backend cfrontend driver \
INCLUDES=$(patsubst %,-I %, $(DIRS))
-COQC=/usr/local/bin/coqc -q $(INCLUDES)
-COQDEP=/usr/local/bin/coqdep $(INCLUDES)
-COQDOC=/usr/local/bin/coqdoc
-COQEXEC=/usr/local/bin/coqtop $(INCLUDES) -batch -load-vernac-source
+COQC=coqc -q $(INCLUDES)
+COQDEP=coqdep $(INCLUDES)
+COQDOC=coqdoc
+COQEXEC=coqtop $(INCLUDES) -batch -load-vernac-source
COQCHK=coqchk $(INCLUDES)
OCAMLBUILD=ocamlbuild
@@ -86,14 +86,14 @@ BACKEND=\
Mach.v Machtyping.v \
Bounds.v Stacklayout.v Stacking.v Stackingproof.v Stackingtyping.v \
Machsem.v \
- Asm.v Asmgen.v Asmgenretaddr.v Asmgenproof1.v Asmgenproof.v
+ Asm.v Asmgen.v Asmgenretaddr.v Asmgenproof1.v Asmgenproof.v
# C front-end modules (in cfrontend/)
CFRONTEND=Csyntax.v Csem.v Cstrategy.v Cexec.v \
Initializers.v Initializersproof.v \
SimplExpr.v SimplExprspec.v SimplExprproof.v \
- Clight.v Cshmgen.v Cshmgenproof.v \
+ Clight.v Cshmgen.v Cshmgenproof.v \
Csharpminor.v Cminorgen.v Cminorgenproof.v
# Putting everything together (in driver/)
diff --git a/cfrontend/Cexec.v b/cfrontend/Cexec.v
index 8253873..f589fab 100644
--- a/cfrontend/Cexec.v
+++ b/cfrontend/Cexec.v
@@ -2087,10 +2087,3 @@ Definition at_final_state (S: state): option int :=
| Returnstate (Vint r) Kstop m => Some r
| _ => None
end.
-
-(*
-*** Local Variables: ***
-*** coq-prog-name: "/usr/local/bin/coqtop" ***
-*** coq-prog-args: ("-emacs-U" "-I" "../lib" "-I" "../common" "-I" "../cfrontend" "-I" "../backend") ***
-*** End: ***
-*) \ No newline at end of file
diff --git a/cfrontend/SimplExpr.v b/cfrontend/SimplExpr.v
index f1b31ac..3144b65 100644
--- a/cfrontend/SimplExpr.v
+++ b/cfrontend/SimplExpr.v
@@ -456,3 +456,9 @@ Definition transl_fundef (fd: C.fundef) : res fundef :=
Definition transl_program (p: C.program) : res program :=
transform_partial_program transl_fundef p.
+
+
+
+
+
+
diff --git a/checklink/Asm_printers.ml b/checklink/Asm_printers.ml
index 39108be..094d51d 100644
--- a/checklink/Asm_printers.ml
+++ b/checklink/Asm_printers.ml
Binary files differ
diff --git a/common/Errors.v b/common/Errors.v
index b04d875..a70ea6e 100644
--- a/common/Errors.v
+++ b/common/Errors.v
@@ -189,8 +189,6 @@ Ltac monadInv1 H :=
| (assertion ?b = OK ?X) =>
let A := fresh "A" in (generalize (assertion_inversion _ H); intro A);
clear H
- | (let _ := _ in ?Y) =>
- monadInv1 Y
| (mmap ?F ?L = OK ?M) =>
generalize (mmap_inversion F L H); intro
end.
@@ -202,7 +200,6 @@ Ltac monadInv H :=
| (bind ?F ?G = OK ?X) => monadInv1 H
| (bind2 ?F ?G = OK ?X) => monadInv1 H
| (assertion _ = OK _) => monadInv1 H
- | (let _ := ?X in OK _ = OK _) => destruct X as [[XT XM] XV]; monadInv1 H
| (?F _ _ _ _ _ _ _ _ = OK _) =>
((progress simpl in H) || unfold F in H); monadInv1 H
| (?F _ _ _ _ _ _ _ = OK _) =>