summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorGravatar jjourdan <jjourdan@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2014-05-23 07:44:28 +0000
committerGravatar jjourdan <jjourdan@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2014-05-23 07:44:28 +0000
commit285d908c5dbd90bff7f03618c7a9e0fa5e287c94 (patch)
tree16dfbc3fefa67782a0d1f1c2588415a3e88458bf /test
parent2525ef0cf03eb06f1d48115b9fe9dab2620511df (diff)
Empty declarations
git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2502 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test')
-rw-r--r--test/regression/Makefile2
-rw-r--r--test/regression/emptydecl.c3
2 files changed, 4 insertions, 1 deletions
diff --git a/test/regression/Makefile b/test/regression/Makefile
index 22e5433..189dbd8 100644
--- a/test/regression/Makefile
+++ b/test/regression/Makefile
@@ -31,7 +31,7 @@ TESTS_DIFF=NaNs
EXTRAS=annot1 commaprec expr2 expr3 expr4 extern1 funct2 funptr1 \
pragmas ptrs1 ptrs2 struct1 struct2 struct3 \
struct4 struct5 struct6 struct9 struct10 types1 seqops \
- singlefloats
+ singlefloats emptydecl
# Test known to fail
FAILURES=funct1
diff --git a/test/regression/emptydecl.c b/test/regression/emptydecl.c
new file mode 100644
index 0000000..f099d44
--- /dev/null
+++ b/test/regression/emptydecl.c
@@ -0,0 +1,3 @@
+;
+
+int x; ;