summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-05-08 07:59:10 +0000
committerGravatar xleroy <xleroy@fca1b0fc-160b-0410-b1d3-a4f43f01ea2e>2013-05-08 07:59:10 +0000
commit054ce39caf060408f6555bcd0b6d90b5bf4c00c5 (patch)
treed65e5e2c2f352b5adbbf2442254e472ca1045797 /test
parente61e84579869cecd6ee0f4ac40d750eeedd6d80f (diff)
Missing case: initialization of a global variable of type _Bool.
Added corresponding test case. git-svn-id: https://yquem.inria.fr/compcert/svn/compcert/trunk@2242 fca1b0fc-160b-0410-b1d3-a4f43f01ea2e
Diffstat (limited to 'test')
-rw-r--r--test/regression/Makefile2
-rw-r--r--test/regression/Results/bool1
-rw-r--r--test/regression/bool.c2
3 files changed, 4 insertions, 1 deletions
diff --git a/test/regression/Makefile b/test/regression/Makefile
index 0d5e4c4..b0663b1 100644
--- a/test/regression/Makefile
+++ b/test/regression/Makefile
@@ -11,7 +11,7 @@ LIBS=$(LIBMATH)
TESTS=int32 int64 floats floats-basics \
expr1 expr6 funptr2 initializers volatile1 volatile2 volatile3 \
funct3 expr5 struct7 struct8 struct11 casts1 casts2 char1 \
- sizeof1 sizeof2 binops
+ sizeof1 sizeof2 binops bool
# Can run, but only in compiled mode, and have reference output in Results
diff --git a/test/regression/Results/bool b/test/regression/Results/bool
index 923c6e2..a8283b8 100644
--- a/test/regression/Results/bool
+++ b/test/regression/Results/bool
@@ -7,3 +7,4 @@ f = 0
g = 1
h = 1
i = 0
+y = 1
diff --git a/test/regression/bool.c b/test/regression/bool.c
index 4f8ed80..e8d8b6e 100644
--- a/test/regression/bool.c
+++ b/test/regression/bool.c
@@ -3,6 +3,7 @@
#include <stdio.h>
int x = 42;
+_Bool y = 777;
int main()
{
@@ -25,5 +26,6 @@ int main()
printf("g = %d\n", g);
printf("h = %d\n", h);
printf("i = %d\n", i);
+ printf("y = %d\n", y);
return 0;
}